summaryrefslogtreecommitdiff
path: root/package/ngrep/ngrep.mk
diff options
context:
space:
mode:
authorWade Berrier <wberrier@gmail.com>2011-09-10 12:59:16 -0600
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-26 10:04:47 +0200
commitfa3410b60605f74b7b14f606b8c827a7f99284bd (patch)
tree246a2bc74cc97d34cf44bd4f984c9a2ad0cb35c1 /package/ngrep/ngrep.mk
parent29903084043bb00b67a7ca1eede1bf4d564fec37 (diff)
new package: ngrep (lightweight alternative to tcpdump)
Signed-off-by: Wade Berrier <wberrier@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ngrep/ngrep.mk')
-rw-r--r--package/ngrep/ngrep.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/ngrep/ngrep.mk b/package/ngrep/ngrep.mk
new file mode 100644
index 000000000..26594dcd5
--- /dev/null
+++ b/package/ngrep/ngrep.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# ngrep
+#
+#############################################################
+
+NGREP_VERSION = 1.45
+NGREP_SOURCE = ngrep-$(NGREP_VERSION).tar.bz2
+NGREP_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/ngrep/ngrep/$(NGREP_VERSION)
+NGREP_INSTALL_STAGING = YES
+NGREP_INSTALL_TARGET = YES
+NGREP_CONF_ENV = LDFLAGS="-lpcre"
+NGREP_CONF_OPT = \
+ --with-pcap-includes=$(STAGING_DIR)/usr/include \
+ --enable-pcre \
+ --with-pcre=$(STAGING_DIR)/usr \
+ --disable-dropprivs
+
+ifeq ($(BR2_INET_IPV6),y)
+NGREP_CONF_OPT += --enable-ipv6
+endif
+
+NGREP_DEPENDENCIES = libpcap pcre
+
+$(eval $(call AUTOTARGETS,package,ngrep))