summaryrefslogtreecommitdiff
path: root/package/openssl/Config.in
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-01-14 10:43:24 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-17 22:00:08 +0100
commit7b9faa03ee7a9ec221b6c3d900d3f9783c4d27b5 (patch)
tree092dddfd3dcdcacc5e1650452bad38062298a25a /package/openssl/Config.in
parent77154539d8115a3fd49d4e0a6376919fa64b2a6f (diff)
openssl: add ocf support
Enable OCF (cryptodev) support for openssl as an option. This requires a patched kernel to export hardware acceleration for openssl to use it. If you lack a patched kernel or support it won't break anything, it will simply fall back to the default software engine from openssl, you'll just have a slightly bigger libssl/libcrypto. Tested with 20100325 release + 20101223 patch from the mailing list. [Peter: slightly tweaked .mk] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openssl/Config.in')
-rw-r--r--package/openssl/Config.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/openssl/Config.in b/package/openssl/Config.in
index 468501435..3e09d88b8 100644
--- a/package/openssl/Config.in
+++ b/package/openssl/Config.in
@@ -21,3 +21,13 @@ config BR2_PACKAGE_OPENSSL_ENGINES
depends on BR2_PACKAGE_OPENSSL
help
Install additional encryption engine libraries.
+
+config BR2_PACKAGE_OPENSSL_OCF
+ bool "openssl ocf support"
+ depends on BR2_PACKAGE_OPENSSL
+ help
+ Enable openssl cryptodev (OCF) hardware acceleration support.
+ This requires kernel patches from the ocf-linux project otherwise
+ you'll just have a bigger openssl library that works as usual.
+
+ http://ocf-linux.sourceforge.net/