summaryrefslogtreecommitdiff
path: root/package/pango/pango.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 22:39:09 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 22:39:09 +0000
commitdc69684e5855a30c5e49f65ed095376107c26243 (patch)
tree18958394ea73445c878d4dbfafe8e00e2d601dec /package/pango/pango.mk
parentd20a2eb97234a807e0cc7e122eb477304231f609 (diff)
pango: generate pango.modules at build time rather than run time
Generate pango.modules using the host tools instead of setting up an init script to do it at run time. Also apply patches to host build to get identical pango.modules file.
Diffstat (limited to 'package/pango/pango.mk')
-rw-r--r--package/pango/pango.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/pango/pango.mk b/package/pango/pango.mk
index ce62f4305..b94a9b581 100644
--- a/package/pango/pango.mk
+++ b/package/pango/pango.mk
@@ -57,7 +57,9 @@ PANGO_DEPENDENCIES = uclibc gettext libintl host-pkgconfig libglib2 $(XSERVER) c
$(eval $(call AUTOTARGETS,package,pango))
$(PANGO_HOOK_POST_INSTALL):
- $(INSTALL) -m 755 package/pango/S25pango $(TARGET_DIR)/etc/init.d/
+ mkdir -p $(TARGET_DIR)/etc/pango
+ $(PANGO_HOST_BINARY) > $(TARGET_DIR)/etc/pango/pango.modules
+ $(SED) 's~$(HOST_DIR)~~g' $(TARGET_DIR)/etc/pango/pango.modules
touch $@
# pango for the host
@@ -68,6 +70,7 @@ $(PANGO_HOST_DIR)/.unpacked: $(DL_DIR)/$(PANGO_SOURCE)
mkdir -p $(@D)
$(INFLATE$(suffix $(PANGO_SOURCE))) $< | \
$(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
+ toolchain/patch-kernel.sh $(@D) package/pango/ \*.patch
touch $@
$(PANGO_HOST_DIR)/.configured: $(PANGO_HOST_DIR)/.unpacked $(PKGCONFIG_HOST_BINARY) $(CAIRO_HOST_BINARY) $(LIBGLIB2_HOST_BINARY)