summaryrefslogtreecommitdiff
path: root/package/pcmcia
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 20:07:55 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 20:07:55 +0200
commit19cd7a3adc66ec2a121152fe149ef769573ee554 (patch)
tree45ba0cc7f7a551f29bd18e3e73b084e50ee0009c /package/pcmcia
parent33070528796dafe90ebab836356fea03f2dc24f9 (diff)
pcmcia: remove deprecated package
As stated on http://pcmcia-cs.sourceforge.net/: "The Linux pcmcia-cs package is officially deprecated. It can only be used with 2.4 and older kernels.". Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pcmcia')
-rw-r--r--package/pcmcia/Config.in9
-rw-r--r--package/pcmcia/pcmcia.mk114
-rw-r--r--package/pcmcia/pcmcia.patch123
3 files changed, 0 insertions, 246 deletions
diff --git a/package/pcmcia/Config.in b/package/pcmcia/Config.in
deleted file mode 100644
index de1e33bba..000000000
--- a/package/pcmcia/Config.in
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_PACKAGE_PCMCIA
- bool "pcmcia"
- depends on BR2_PACKAGE_LINUX
- # The website says it's deprecated after 2.4.x kernels
- depends on BR2_DEPRECATED
- help
- PCMCIA tools for Linux.
-
- http://pcmcia-cs.sourceforge.net/
diff --git a/package/pcmcia/pcmcia.mk b/package/pcmcia/pcmcia.mk
deleted file mode 100644
index 8080b8723..000000000
--- a/package/pcmcia/pcmcia.mk
+++ /dev/null
@@ -1,114 +0,0 @@
-#############################################################
-#
-# pcmcia card services
-#
-#############################################################
-# Copyright (C) 2001-2003 by Erik Andersen <andersen@codepoet.org>
-# Copyright (C) 2002 by Tim Riker <Tim@Rikers.org>
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Library General Public License as
-# published by the Free Software Foundation; either version 2 of the
-# License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Library General Public License for more details.
-#
-# You should have received a copy of the GNU Library General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
-# USA
-
-PCMCIA_SOURCE:=pcmcia-cs-3.2.7.tar.gz
-PCMCIA_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/pcmcia-cs
-PCMCIA_DIR:=$(BUILD_DIR)/pcmcia-cs-3.2.7
-PCMCIA_CAT:=$(ZCAT)
-
-$(DL_DIR)/$(PCMCIA_SOURCE):
- $(call DOWNLOAD,$(PCMCIA_SITE),$(PCMCIA_SOURCE))
-
-pcmcia-source: $(DL_DIR)/$(PCMCIA_SOURCE)
-
-$(PCMCIA_DIR)/.unpacked: $(DL_DIR)/$(PCMCIA_SOURCE)
- $(PCMCIA_CAT) $(DL_DIR)/$(PCMCIA_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- touch $(PCMCIA_DIR)/.unpacked
-
-$(PCMCIA_DIR)/.patched: $(PCMCIA_DIR)/.unpacked
- toolchain/patch-kernel.sh $(PCMCIA_DIR) package/pcmcia/ pcmcia\*.patch
- touch $(PCMCIA_DIR)/.patched
-
-$(PCMCIA_DIR)/.configured: $(PCMCIA_DIR)/.patched
- ( cd $(PCMCIA_DIR); ./Configure --kernel=$(LINUX26_DIR) --noprompt \
- --rcdir=/etc --arch=$(ARCH) --trust --srctree --nocardbus \
- --sysv --kcc=$(TARGET_CROSS)gcc --ucc="$(TARGET_CC)" --ld=$(TARGET_CROSS)ld \
- --target=$(TARGET_DIR))
- $(SED) "s/pump/udhcpc/" $(PCMCIA_DIR)/etc/network
- $(SED) "s/ide_cs/ide-cs/" $(PCMCIA_DIR)/etc/config
- $(SED) "s/bind \"wvlan_cs\"/bind \"orinoco_cs\"/g" $(PCMCIA_DIR)/etc/config
- touch $(PCMCIA_DIR)/.configured
-
-$(PCMCIA_DIR)/cardmgr/cardmgr: $(PCMCIA_DIR)/.configured
- $(MAKE) -C $(PCMCIA_DIR) -i all
- -A=`find $(PCMCIA_DIR) -type f -perm +111`; \
- for fo in $$A; do \
- file $$fo | grep "ELF" | grep "executable" > /dev/null 2>&1; \
- if [ $$? = 0 ]; then \
- $(STRIPCMD) $$fo; \
- fi; \
- done
- touch -c $(PCMCIA_DIR)/cardmgr/cardmgr
-
-$(TARGET_DIR)/sbin/cardmgr: $(PCMCIA_DIR)/cardmgr/cardmgr
- rm -rf $(TARGET_DIR)/etc/pcmcia
- $(MAKE) -i -C $(PCMCIA_DIR) install
- rm -rf $(TARGET_DIR)/usr/man
- rm -rf $(TARGET_DIR)/usr/share/man
- rm -rf $(TARGET_DIR)/usr/X11R6/man
- rm -rf $(TARGET_DIR)/etc/rc.d
- rm -rf $(TARGET_DIR)/etc/rc?.d
- rm -f $(TARGET_DIR)/etc/init.d/pcmcia*
- rm -f $(TARGET_DIR)/sbin/dump_cis $(TARGET_DIR)/sbin/pack_cis
- rm -f $(TARGET_DIR)/usr/share/pnp.ids $(TARGET_DIR)/sbin/lspnp $(TARGET_DIR)/sbin/setpnp
- rm -f $(TARGET_DIR)/sbin/pcinitrd
- rm -f $(TARGET_DIR)/sbin/probe
- rm -f $(TARGET_DIR)/sbin/ide_info
- rm -f $(TARGET_DIR)/sbin/scsi_info
- rm -f $(TARGET_DIR)/sbin/ftl_check
- rm -f $(TARGET_DIR)/sbin/ftl_format
- rm -f $(TARGET_DIR)/usr/X11R6/bin/xcardinfo
- rm -rf $(TARGET_DIR)/etc/sysconfig
- mkdir -p $(TARGET_DIR)/etc/default
- cp -f $(PCMCIA_DIR)/etc/pcmcia $(TARGET_DIR)/etc/default/
- cp -f $(PCMCIA_DIR)/etc/rc.pcmcia $(TARGET_DIR)/etc/init.d/S30pcmcia
- rm -rf $(TARGET_DIR)/etc/pcmcia/cis
- chmod a+x $(TARGET_DIR)/etc/init.d/S30pcmcia
- chmod -R u+w $(TARGET_DIR)/etc/pcmcia/*
-
-# use busybox depmod.pl so we need the sources unpacked
-$(PCMCIA_DIR)/.modules.dep: $(BUSYBOX_DIR)/.configured $(TARGET_DIR)/lib/modules
- [ -d $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION) ] && \
- $(BUSYBOX_DIR)/examples/depmod.pl \
- -b $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/ \
- -F $(LINUX26_DIR)/System.map \
- > $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep
- touch $(PCMCIA_DIR)/.modules.dep
-
-pcmcia: linux26 $(TARGET_DIR)/sbin/cardmgr $(PCMCIA_DIR)/.modules.dep
-
-pcmcia-clean:
- rm -f $(TARGET_DIR)/sbin/cardmgr
- -$(MAKE) -C $(PCMCIA_DIR) clean
- rm -f $(PCMCIA_DIR)/.configured $(PCMCIA_DIR)/config.out
-
-pcmcia-dirclean:
- rm -rf $(PCMCIA_DIR)
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_PCMCIA),y)
-TARGETS+=pcmcia
-endif
diff --git a/package/pcmcia/pcmcia.patch b/package/pcmcia/pcmcia.patch
deleted file mode 100644
index 121435fc1..000000000
--- a/package/pcmcia/pcmcia.patch
+++ /dev/null
@@ -1,123 +0,0 @@
---- pcmcia-cs-3.1.34/etc/config.opts.orig Tue Jul 9 09:36:23 2002
-+++ pcmcia-cs-3.1.34/etc/config.opts Tue Jul 9 09:37:47 2002
-@@ -5,7 +5,7 @@
-
- # System resources available for PCMCIA devices
-
--include port 0x100-0x4ff, port 0x800-0x8ff, port 0xc00-0xcff
-+include port 0x100-0x4ff, port 0xc00-0xcff
- include memory 0xc0000-0xfffff
- include memory 0xa0000000-0xa0ffffff, memory 0x60000000-0x60ffffff
-
-diff -urN pcmcia-cs-3.2.3.orig/etc/shared pcmcia-cs-3.2.3/etc/shared
---- pcmcia-cs-3.2.3.orig/etc/shared 2002-08-18 21:21:11.000000000 -0600
-+++ pcmcia-cs-3.2.3/etc/shared 2003-02-14 05:05:07.000000000 -0700
-@@ -2,6 +2,8 @@
- # shared 1.31 2002/08/19 03:21:11 (David Hinds)
- #
-
-+umask 022
-+
- usage ()
- {
- echo "usage: $0 [action] [device name]"
---- /dev/null 2003-01-21 22:14:35.000000000 -0700
-+++ pcmcia-cs-3.2.4/etc/pcmcia 2003-06-09 12:04:02.000000000 -0600
-@@ -0,0 +1,6 @@
-+# Defaults for pcmcia (sourced by /etc/init.d/S30pcmcia)
-+PCMCIA=yes
-+PCIC=yenta_socket
-+PCIC_OPTS=
-+CORE_OPTS=
-+CARDMGR_OPTS=
---- pcmcia-cs-3.2.4/etc/rc.pcmcia.orig 2002-08-08 00:43:43.000000000 -0600
-+++ pcmcia-cs-3.2.4/etc/rc.pcmcia 2003-06-09 15:17:28.000000000 -0600
-@@ -4,6 +4,8 @@
- #
- # This is designed to work in BSD as well as SysV init setups. See
- # the HOWTO for customization instructions.
-+# Modified to comply with Debian's standards by Brian Mays
-+# <brian@debian.org>.
-
- # Tags for Red Hat init configuration tools
- #
-@@ -26,9 +28,9 @@
- done
-
- # Source PCMCIA configuration, if available
--if [ -f /etc/pcmcia.conf ] ; then
-+if [ -f /etc/default/pcmcia ] ; then
- # Debian startup option file
-- . /etc/pcmcia.conf
-+ . /etc/default/pcmcia
- elif [ -f /etc/sysconfig/pcmcia ] ; then
- # Red Hat startup option file
- . /etc/sysconfig/pcmcia
-@@ -50,9 +52,22 @@
- done
- if [ "$PCMCIA" -a "$PCMCIA" != "yes" ] ; then exit 0 ; fi
-
-+# Debian modification: Fix PCIC for stand-alone modules.
-+# yenta_socket -> i82365 on these systems.
-+# Existence of a standalone module implies that it is preferred.
-+if [ -d /lib/modules/preferred ] ; then
-+ PC=/lib/modules/preferred/pcmcia
-+else
-+ PC=/lib/modules/`uname -r`/pcmcia
-+fi
-+if [ "$PCIC" = yenta_socket -a -e $PC/i82365.o \
-+ -a ! -L $PC/i82365.o ]; then
-+ PCIC=i82365
-+fi
-+
- usage()
- {
-- echo "Usage: $0 {start|stop|status|restart|reload}"
-+ echo "Usage: $0 {start|stop|status|restart|reload|force-reload}"
- }
-
- cleanup()
-@@ -84,7 +99,7 @@
- SC=/var/lib/pcmcia/scheme
- RUN=/var/lib/pcmcia
- else
-- SC=/var/run/pcmcia-scheme
-+ SC=/var/lib/misc/pcmcia-scheme
- RUN=/var/run
- fi
- if [ -L $SC -o ! -O $SC ] ; then rm -f $SC ; fi
-@@ -154,7 +172,7 @@
- ;;
-
- status)
-- pid=`/sbin/pidof cardmgr`
-+ pid=`/bin/pidof cardmgr`
- if [ "$pid" != "" ] ; then
- echo "cardmgr (pid $pid) is running..."
- EXITCODE=0
-@@ -164,12 +182,18 @@
- fi
- ;;
-
-- restart|reload)
-+ restart)
- $0 stop
- $0 start
- EXITCODE=$?
- ;;
-
-+ reload|force-reload)
-+ echo "Reloading $DESC configuration files."
-+ kill -1 `cat /var/run/cardmgr.pid` 2>/dev/null
-+ EXITCODE=0
-+ ;;
-+
- *)
- usage
- ;;
-@@ -179,4 +203,4 @@
- done
-
- # Only exit if we're in our own subshell
--case $0 in *rc.pcmcia) exit $EXITCODE ;; esac
-+case $0 in *pcmcia) exit $EXITCODE ;; esac