summaryrefslogtreecommitdiff
path: root/package/pcmcia
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/pcmcia
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/pcmcia')
-rw-r--r--package/pcmcia/Makefile.in3
-rw-r--r--package/pcmcia/pcmcia.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/pcmcia/Makefile.in b/package/pcmcia/Makefile.in
deleted file mode 100644
index eb501d6d4..000000000
--- a/package/pcmcia/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_PCMCIA)),y)
-TARGETS+=pcmcia
-endif
diff --git a/package/pcmcia/pcmcia.mk b/package/pcmcia/pcmcia.mk
index 8ffaaf68b..31efd5c9b 100644
--- a/package/pcmcia/pcmcia.mk
+++ b/package/pcmcia/pcmcia.mk
@@ -105,3 +105,11 @@ pcmcia-clean:
pcmcia-dirclean:
rm -rf $(PCMCIA_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_PCMCIA)),y)
+TARGETS+=pcmcia
+endif