summaryrefslogtreecommitdiff
path: root/package/pkg-autotargets.mk
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-07-14 22:31:19 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-15 12:36:23 +0200
commitcbf1691ef48f8a87587713f981054c9fef22e2c4 (patch)
treebf8779cd7e2857541aae82d17f812dca448cbce5 /package/pkg-autotargets.mk
parent99dd58418daee463074d7fd38d6ea98aca97d304 (diff)
pkg-infra: remove self-dependency from host packages
When HOST_XXX_DEPENDENCIES are derived automatically from XXX_DEPENDENCIES, a self-dependency is created if host-xxx is a dependency of xxx. This was the case for miniperl. Filter out the self-dependency. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-autotargets.mk')
-rw-r--r--package/pkg-autotargets.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-autotargets.mk b/package/pkg-autotargets.mk
index c9887c2e1..d31230dd7 100644
--- a/package/pkg-autotargets.mk
+++ b/package/pkg-autotargets.mk
@@ -201,7 +201,7 @@ endef
# This must be repeated from GENTARGETS_INNER, otherwise we get an empty
# _DEPENDENCIES if _AUTORECONF is YES. Also filter the result of _AUTORECONF
# away from the non-host rule
-$(2)_DEPENDENCIES ?= $(filter-out host-automake host-autoconf host-libtool,\
+$(2)_DEPENDENCIES ?= $(filter-out host-automake host-autoconf host-libtool $(1),\
$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))