summaryrefslogtreecommitdiff
path: root/package/pkg-config/pkg-config.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-30 00:33:00 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-30 00:37:53 +0100
commit50bda85e88fa10be32733dd0334aea93519bc915 (patch)
tree17ec48ef7821e5e40adc112cf19dd7d58454e353 /package/pkg-config/pkg-config.mk
parentb4df2ea27fc28734978ff8a52811dc23d5d1c221 (diff)
pkg-config: add --with-sysroot option for compiled in default sysroot setting
Similar to the --with-pc-path option. It works just like the existing PKG_CONFIG_SYSROOT_DIR environment variable, but compiled in. The environment variable overrides this default setting if set. This way we don't need to pass PKG_CONFIG_SYSROOT_DIR in the environment when building for the target, and it is easier to reuse pkg-config outside BR (E.G. for the SDK) without having to setup special environment variables. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-config/pkg-config.mk')
-rw-r--r--package/pkg-config/pkg-config.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/pkg-config/pkg-config.mk b/package/pkg-config/pkg-config.mk
index 413853d97..bb52db87d 100644
--- a/package/pkg-config/pkg-config.mk
+++ b/package/pkg-config/pkg-config.mk
@@ -13,8 +13,11 @@ PKG_CONFIG_CONF_OPT = --with-installed-glib
HOST_PKG_CONFIG_CONF_OPT = \
--with-pc-path="$(STAGING_DIR)/usr/lib/pkgconfig" \
+ --with-sysroot="$(STAGING_DIR)" \
--disable-static
+HOST_PKG_CONFIG_AUTORECONF = YES
+
$(eval $(call AUTOTARGETS,package,pkg-config))
$(eval $(call AUTOTARGETS,package,pkg-config,host))