summaryrefslogtreecommitdiff
path: root/package/portage
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/portage
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/portage')
-rw-r--r--package/portage/Makefile.in3
-rw-r--r--package/portage/portage.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/portage/Makefile.in b/package/portage/Makefile.in
deleted file mode 100644
index c9f03e518..000000000
--- a/package/portage/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_PORTAGE)),y)
-TARGETS+=portage
-endif
diff --git a/package/portage/portage.mk b/package/portage/portage.mk
index 7634832b9..7677920ad 100644
--- a/package/portage/portage.mk
+++ b/package/portage/portage.mk
@@ -104,3 +104,11 @@ portage-clean:
portage-dirclean:
rm -rf $(PORTAGE_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_PORTAGE)),y)
+TARGETS+=portage
+endif