summaryrefslogtreecommitdiff
path: root/package/pppd/pppd.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-09-11 08:59:56 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-11 08:59:56 +0200
commit94ce13a56f238bbba01bdfc893cfbc4e62169287 (patch)
treeab737126d3df66e7888ca1aa1409f8eba1382ec4 /package/pppd/pppd.mk
parent0cf33385468889c7ec1ddbdae2c81ecabc4f9584 (diff)
pppd: fix build with 3.5+ kernel headers
Fixes http://autobuild.buildroot.net/results/8a9369fece696e012249b865708ffee533c5318a Pppd bundles some, but not all needed kernel headers. In Linux 3.5 (and before that 2.6.35) if_pppol2tp.h was changed, so the embedded copy was no longer compatible. if_pppol2tp.h has been part of the exported kernel headers since 2.6.23, so simply drop the bundled copy and use the kernel headers instead, similar to how it is done in Gentoo: https://bugs.gentoo.org/show_bug.cgi?id=427684 Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pppd/pppd.mk')
-rw-r--r--package/pppd/pppd.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/pppd/pppd.mk b/package/pppd/pppd.mk
index 259d1dc6d..b13dbabab 100644
--- a/package/pppd/pppd.mk
+++ b/package/pppd/pppd.mk
@@ -23,6 +23,15 @@ ifeq ($(BR2_INET_IPV6),y)
PPPD_MAKE_OPT += HAVE_INET6=y
endif
+# pppd bundles some but not all of the needed kernel headers. The embedded
+# if_pppol2tp.h is unfortunately not compatible with kernel headers > 2.6.34,
+# and has been part of the kernel headers since 2.6.23, so drop it
+define PPPD_DROP_INTERNAL_IF_PPOL2TP_H
+ $(RM) $(@D)/include/linux/if_pppol2tp.h
+endef
+
+PPPD_POST_EXTRACT_HOOKS += PPPD_DROP_INTERNAL_IF_PPOL2TP_H
+
define PPPD_CONFIGURE_CMDS
$(SED) 's/FILTER=y/#FILTER=y/' $(PPPD_DIR)/pppd/Makefile.linux
$(SED) 's/ifneq ($$(wildcard \/usr\/include\/pcap-bpf.h),)/ifdef FILTER/' $(PPPD_DIR)/*/Makefile.linux