summaryrefslogtreecommitdiff
path: root/package/python-nfc/python-nfc-add-setup-py.patch
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-07-20 09:58:12 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-20 21:08:25 +0200
commit45166f30dc40ce810831657c27724a3b5a57f2ad (patch)
treef51eda59cf2f198420f923e228d240da6faaafbb /package/python-nfc/python-nfc-add-setup-py.patch
parent1677d40822f032fc09ab271a3d14eb6f445cc91b (diff)
python-nfc: new package
[thomas.petazzoni@free-electrons.com: add patch that creates a standard setup.py file. This allows the .pyc files to be generated at build time, and installed into the target. This is important because by default, Buildroot removes all .py files from the target, to keep only the .pyc files. The python-nfc.mk file was changed to use this setup.py standard build process.] Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-nfc/python-nfc-add-setup-py.patch')
-rw-r--r--package/python-nfc/python-nfc-add-setup-py.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/python-nfc/python-nfc-add-setup-py.patch b/package/python-nfc/python-nfc-add-setup-py.patch
new file mode 100644
index 000000000..307b74984
--- /dev/null
+++ b/package/python-nfc/python-nfc-add-setup-py.patch
@@ -0,0 +1,26 @@
+Add simple setup.py
+
+Having a setup.py allows to easily get the .py files compiled into
+.pyc, which is good because by default, Buildroot only keeps .pyc
+files on the target.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/setup.py
+===================================================================
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,13 @@
++#!/usr/bin/env python
++
++from distutils.core import setup
++
++setup(name='NFC',
++ version='1.0',
++ description='Python NFC',
++ author='Stephen Tiedemann',
++ author_email='stephen.tiedemann@googlemail.com',
++ url='https://launchpad.net/nfcpy',
++ packages=['nfc', 'nfc/dev', 'nfc/llcp', 'nfc/ndef',
++ 'nfc/npp', 'nfc/snep'],
++ )