summaryrefslogtreecommitdiff
path: root/package/python/Config.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-26 10:28:49 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-01-25 08:59:57 +0100
commite3418f69cf2f17d54dfb521adedbe8abf6e35927 (patch)
treeaa465725122a3ac95ba4656e31cfd129b8bb0609 /package/python/Config.in
parentb06e7ac4e135a01ddb8914c779dff2bda25e00b1 (diff)
python: convert to autotargets, bump to 2.7.1, many improvements
This commit does a number of changes and improvements to the Python interpreter package : * It converts the .mk file to the AUTOTARGETS infrastructure. Even though Python uses only autoconf and not automake, the AUTOTARGETS is a fairly good fit for the Python interpreter, so we make use of it. * It bumps the version to 2.7.1. As this is a minor release compared to 2.7, there are no particular changes needed because of this bump. All changes done to the package are cleanups and improvements unrelated to the version bump. * It uses the system libffi. Until now, Python was building its own libffi (a library used by interprets to build code that makes function call at runtime). Using the Python internal libffi was not working as Python was not passing the appropriate arguments down to libffi ./configure script. And it sounded better to use a system-wide libffi, that could potentially be used by other packages as well. This libffi is needed for the ctypes Python module. * Remove all "depends on BR2_PACKAGE_PYTHON" by moving all Python-related options under a "if BR2_PACKAGE_PYTHON ... endif" condition. * Make the installation of pre-compiled Python modules (.pyc) the default, since they are smaller and do not need to be compiled on the target. It is still possible to install uncompiled modules, or both the uncompiled and pre-compiled versions. * The options to select the set of Python modules to compile has been moved to a submenu. * The codecscjk (Japanese, Korean and Chinese codecs) module is no longer enabled by default. * The commented options for gdbm and nis in Python have been removed. Those were not supported, so let's get rid of unused code. * The option for the tkinker module in Python has been removed, since we don't have a package for Tk in Buildroot. * Options for the bzip2, sqlite and zlib modules have been added, since those modules have external dependencies. * The set of patches has been completely reworked and extended, with more fine-grained patches and newer functionalities. The patches are split in two categories: - Patches that make various modifications to the Python build system to support cross-compilation or make some minor modifications. Those patches are numbered from 0 to 100. - Patches that add configuration options to the Python build system in order to enable/disable the compilation of Python extensions or modules (test modules, pydoc, lib2to3, sqlite, tk, curses, expat, codecs-cjk, nis, unicodedata, database modules, ssl, bzip2, zlib). These patches are numbered from 100 to 200. All features of the previous four patches are preserved, but they are organized differently and the patches have been renamed. This makes it difficult to see the differences from the existing patches. * The host Python interpreter is now installed in $(HOST_DIR), since it is used to build third party Python modules. * The BR2_PACKAGE_PYTHON_DEV option is removed since BR2_HAVE_DEVFILES already does the necessary work. * The "make -i install" workaround introduced by Maxime Ripard is no longer needed. It was caused by the compilation of the tests that required the unicodedata module (which wasn't built in the host Python interpreter). Since we no longer compile the Python tests, the problem doesn't exist anymore and we can avoid this "-i" option. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python/Config.in')
-rw-r--r--package/python/Config.in65
1 files changed, 28 insertions, 37 deletions
diff --git a/package/python/Config.in b/package/python/Config.in
index e77d7aa40..11aa2670d 100644
--- a/package/python/Config.in
+++ b/package/python/Config.in
@@ -1,6 +1,7 @@
config BR2_PACKAGE_PYTHON
bool "python"
depends on BR2_USE_WCHAR
+ select BR2_PACKAGE_LIBFFI
help
The python language interpreter.
@@ -9,17 +10,11 @@ config BR2_PACKAGE_PYTHON
comment "python requires a toolchain with WCHAR support"
depends on !BR2_USE_WCHAR
-config BR2_PACKAGE_PYTHON_DEV
- depends on BR2_PACKAGE_PYTHON
- bool "development files on target"
- help
- If enabled, development files (headers and static libpython) will be
- installed on the target.
+if BR2_PACKAGE_PYTHON
choice
- prompt "Module format to install"
- depends on BR2_PACKAGE_PYTHON
- default BR2_PACKAGE_PYTHON_PY_ONLY
+ prompt "python module format to install"
+ default BR2_PACKAGE_PYTHON_PYC_ONLY
help
Select Python module format to install on target (py, pyc or both)
@@ -34,51 +29,40 @@ config BR2_PACKAGE_PYTHON_PY_PYC
endchoice
+menu "core python modules"
+
comment "The following modules are unusual or require extra libraries"
- depends on BR2_PACKAGE_PYTHON
+
+config BR2_PACKAGE_PYTHON_BZIP2
+ select BR2_PACKAGE_BZIP2
+ bool "bzip2 module"
+ help
+ bzip2 module for Python
config BR2_PACKAGE_PYTHON_BSDDB
- depends on BR2_PACKAGE_PYTHON
select BR2_PACKAGE_BERKELEYDB
bool "bsddb module"
help
bsddb module for Python.
config BR2_PACKAGE_PYTHON_CODECSCJK
- depends on BR2_PACKAGE_PYTHON
bool "codecscjk module"
- default y
help
Chinese/Japanese/Korean codecs module for Python (large).
config BR2_PACKAGE_PYTHON_CURSES
- depends on BR2_PACKAGE_PYTHON
select BR2_PACKAGE_NCURSES
bool "curses module"
help
curses module for Python.
-# config BR2_PACKAGE_PYTHON_GDBM
-# depends on BR2_PACKAGE_PYTHON
-# bool "gdbm module"
-# help
-# gdbm module for Python.
-
-# config BR2_PACKAGE_PYTHON_NIS
-# depends on BR2_PACKAGE_PYTHON
-# bool "nis module"
-# help
-# nis module for Python.
-
config BR2_PACKAGE_PYTHON_PYEXPAT
- depends on BR2_PACKAGE_PYTHON
select BR2_PACKAGE_EXPAT
bool "pyexpat"
help
pyexpat module for Python.
config BR2_PACKAGE_PYTHON_READLINE
- depends on BR2_PACKAGE_PYTHON
select BR2_PACKAGE_READLINE
bool "readline"
help
@@ -86,22 +70,29 @@ config BR2_PACKAGE_PYTHON_READLINE
editing in the Python shell).
config BR2_PACKAGE_PYTHON_SSL
- depends on BR2_PACKAGE_PYTHON
select BR2_PACKAGE_OPENSSL
bool "ssl"
help
_ssl module for Python (required for https in urllib etc).
-config BR2_PACKAGE_PYTHON_TKINTER
- depends on BR2_PACKAGE_PYTHON
- select BR2_PACKAGE_TCL
- bool "tkinter module"
- help
- tkinter module for Python.
-
config BR2_PACKAGE_PYTHON_UNICODEDATA
- depends on BR2_PACKAGE_PYTHON
bool "unicodedata module"
default y
help
Unicode character database (used by stringprep module) (large).
+
+config BR2_PACKAGE_PYTHON_SQLITE
+ bool "sqlite module"
+ select BR2_PACKAGE_SQLITE
+ help
+ SQLite database support
+
+config BR2_PACKAGE_PYTHON_ZLIB
+ bool "zlib module"
+ select BR2_PACKAGE_ZLIB
+ help
+ zlib support in Python
+
+endmenu
+
+endif