summaryrefslogtreecommitdiff
path: root/package/python/python-2.7-003-no-import-when-cross-compiling.patch
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:24:46 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:24:46 +0100
commit0eef30440e9597b2c0b9c7a0340a3986a7ea2a65 (patch)
treef8e74a929418c8085bc09dd5606a10e356923c74 /package/python/python-2.7-003-no-import-when-cross-compiling.patch
parent4c6a451ac9fab16abcda5834ed4a9b728091ab9e (diff)
parent6ea3c8bd4dabe2b11a8beecb6a641336e6e90f3c (diff)
Merge branch 'for-2011.02/python-bump' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'package/python/python-2.7-003-no-import-when-cross-compiling.patch')
-rw-r--r--package/python/python-2.7-003-no-import-when-cross-compiling.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/python/python-2.7-003-no-import-when-cross-compiling.patch b/package/python/python-2.7-003-no-import-when-cross-compiling.patch
new file mode 100644
index 000000000..162ba5031
--- /dev/null
+++ b/package/python/python-2.7-003-no-import-when-cross-compiling.patch
@@ -0,0 +1,26 @@
+Disable import check when cross-compiling
+
+Once Python has compiled an extension (i.e some C code, potentially
+linked to a library), it tries to import it. This cannot work in
+cross-compilation mode, so we just disable this check.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ setup.py | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+Index: Python-2.7.1/setup.py
+===================================================================
+--- Python-2.7.1.orig/setup.py
++++ Python-2.7.1/setup.py
+@@ -304,6 +304,10 @@
+ self.announce('WARNING: skipping import check for Cygwin-based "%s"'
+ % ext.name)
+ return
++ if os.environ.get('CROSS_COMPILING') == 'yes':
++ self.announce('WARNING: skipping import check for cross compiled "%s"'
++ % ext.name)
++ return
+ ext_filename = os.path.join(
+ self.build_lib,
+ self.get_ext_filename(self.get_ext_fullname(ext.name)))