summaryrefslogtreecommitdiff
path: root/package/python/python-2.7-004-no-host-headers-libs.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-18 18:05:22 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-18 21:05:01 +0200
commita21642c7eb06eeffe621e7eaef1a85cb9b4589f8 (patch)
tree7ad88cac4838dc3968401f6657f7e6cf8f362630 /package/python/python-2.7-004-no-host-headers-libs.patch
parent16d6e9b3420e78a89960b8b68202ea46a618810d (diff)
python: fix build by adding some more patches
The removal of -L flags from TARGET_LDFLAGS in 7e3e8ec040b06d6e2fb69e55c004f1ebc02c76d0 has trigerred some more issues with Python, requiring some more hacky fixes. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python/python-2.7-004-no-host-headers-libs.patch')
-rw-r--r--package/python/python-2.7-004-no-host-headers-libs.patch22
1 files changed, 17 insertions, 5 deletions
diff --git a/package/python/python-2.7-004-no-host-headers-libs.patch b/package/python/python-2.7-004-no-host-headers-libs.patch
index 033776d46..aed8de6c8 100644
--- a/package/python/python-2.7-004-no-host-headers-libs.patch
+++ b/package/python/python-2.7-004-no-host-headers-libs.patch
@@ -26,7 +26,19 @@ Index: Python-2.7.1/setup.py
# Add paths specified in the environment variables LDFLAGS and
# CPPFLAGS for header and library files.
-@@ -388,17 +389,6 @@
+@@ -360,10 +361,7 @@
+ # directly since an inconsistently reproducible issue comes up where
+ # the environment variable is not set even though the value were passed
+ # into configure and stored in the Makefile (issue found on OS X 10.3).
+- for env_var, arg_name, dir_list in (
+- ('LDFLAGS', '-R', self.compiler.runtime_library_dirs),
+- ('LDFLAGS', '-L', self.compiler.library_dirs),
+- ('CPPFLAGS', '-I', self.compiler.include_dirs)):
++ for env_var, arg_name, dir_list in ():
+ env_val = sysconfig.get_config_var(env_var)
+ if env_val:
+ # To prevent optparse from raising an exception about any
+@@ -388,17 +386,6 @@
for directory in reversed(options.dirs):
add_dir_to_list(dir_list, directory)
@@ -44,7 +56,7 @@ Index: Python-2.7.1/setup.py
try:
have_unicode = unicode
except NameError:
-@@ -407,11 +397,16 @@
+@@ -407,11 +394,16 @@
# lib_dirs and inc_dirs are used to search for files;
# if a file is found in one of those directories, it can
# be assumed that no additional -I,-L directives are needed.
@@ -66,7 +78,7 @@ Index: Python-2.7.1/setup.py
exts = []
missing = []
-@@ -844,6 +839,9 @@
+@@ -844,6 +836,9 @@
db_inc_paths.append('/pkg/db-3.%d/include' % x)
db_inc_paths.append('/opt/db-3.%d/include' % x)
@@ -76,7 +88,7 @@ Index: Python-2.7.1/setup.py
# Add some common subdirectories for Sleepycat DB to the list,
# based on the standard include directories. This way DB3/4 gets
# picked up when it is installed in a non-standard prefix and
-@@ -996,6 +994,9 @@
+@@ -996,6 +991,9 @@
MIN_SQLITE_VERSION = ".".join([str(x)
for x in MIN_SQLITE_VERSION_NUMBER])
@@ -86,7 +98,7 @@ Index: Python-2.7.1/setup.py
# Scan the default include directories before the SQLite specific
# ones. This allows one to override the copy of sqlite on OSX,
# where /usr/include contains an old version of sqlite.
-@@ -1095,6 +1096,8 @@
+@@ -1095,6 +1093,8 @@
# the more recent berkeleydb's db.h file first in the include path
# when attempting to compile and it will fail.
f = "/usr/include/db.h"