summaryrefslogtreecommitdiff
path: root/package/qt/qt.mk
diff options
context:
space:
mode:
authorMichael Roth <mroth@nessie.de>2009-10-07 11:20:41 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-09 14:56:42 +0200
commitd6d7f13cd0ef76790c15ea9bef73c7e2eb5224bc (patch)
tree49a94f3467664855a960c981dda5c06ef14791db /package/qt/qt.mk
parent82f1ccf4c84101c2611e6e9e7e118258f7c90757 (diff)
qt: remove Kconfig option to enable all pixel depths
The Kconfig menu "Pixel depths" of Qt provides a list with all selectable pixel depths and additionally the option "all". When "all" is selected, the list with all available pixel depths disappears. Because this disappearing of available pixel depths makes no sense under usability aspects, simply remove the option "all". The user could enable all available pixel depths by selecting each individual depth anyway. So no functionality is lost. Signed-off-by: Michael Roth <mroth@nessie.de> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt/qt.mk')
-rw-r--r--package/qt/qt.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index ae03fa684..0bbf64405 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -62,9 +62,7 @@ endif
### Pixel depths
-ifeq ($(BR2_PACKAGE_QT_PIXEL_DEPTH_ALL),y)
-QT_PIXEL_DEPTHS = all
-else
+QT_PIXEL_DEPTHS := # empty
ifeq ($(BR2_PACKAGE_QT_PIXEL_DEPTH_1),y)
QT_PIXEL_DEPTHS += 1
endif
@@ -92,7 +90,6 @@ endif
ifeq ($(BR2_PACKAGE_QT_PIXEL_DEPTH_32),y)
QT_PIXEL_DEPTHS += 32
endif
-endif
ifneq ($(QT_PIXEL_DEPTHS),)
QT_CONFIGURE += -depths $(subst $(space),$(comma),$(strip $(QT_PIXEL_DEPTHS)))
endif