summaryrefslogtreecommitdiff
path: root/package/qt/qt.mk
diff options
context:
space:
mode:
authorMichael Roth <mroth@nessie.de>2009-10-07 11:20:39 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-09 14:54:27 +0200
commit82f1ccf4c84101c2611e6e9e7e118258f7c90757 (patch)
tree879e6e891fa50a02a42dcc5097f19ea3591b6e05 /package/qt/qt.mk
parentf9854762255617f49b08e5d5a87f76638b9a5701 (diff)
qt: disable precompiled headers when ccache is enabled
ccache and precompiled headers don't work together, so disable precompiled headers when ccache is enabled. The benefit of ccache compiling Qt a second or more time is much higher than the costs of disabled precompiled headers in the first run. Signed-off-by: Michael Roth <mroth@nessie.de> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt/qt.mk')
-rw-r--r--package/qt/qt.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 37849f98b..ae03fa684 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -315,6 +315,11 @@ else
QT_CONFIGURE+= -no-stl
endif
+# ccache and precompiled headers don't play well together
+ifeq ($(BR2_CCACHE),y)
+QT_CONFIGURE += -no-pch
+endif
+
BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
# Figure out what libs to install in the target