summaryrefslogtreecommitdiff
path: root/package/qt/qt.mk
diff options
context:
space:
mode:
authorOrmund Williams <ormundw@panix.com>2010-01-13 17:55:52 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2010-01-18 09:46:19 +0100
commitbc41dc5b8fbb637902dfaa0171deb5d6c63909e0 (patch)
tree3a96e51785d02bcccffa12f08af454cc1c477bcb /package/qt/qt.mk
parent5a352cdeba03856fa2d0cf12c707fd80704ebfdd (diff)
qt: Re-enable workaround for building on x86 for x86 target, also check for x86_64
[Peter: combined x86 + x86-64 logic, simplified] Signed-off-by: Ormund Williams <ormundw@panix.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt/qt.mk')
-rw-r--r--package/qt/qt.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index a3a466ae3..78b2eec3a 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -352,6 +352,16 @@ endif
BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
+# x86x86fix
+# Workaround Qt Embedded bug when crosscompiling for x86 under x86 with linux
+# host. It's unclear if this would happen on other hosts.
+ifneq ($(findstring pc-linux,$(BR2_GNU_BUILD_SUFFIX)),)
+ifneq ($(findstring x86,$(BR2_PACKAGE_QT_EMB_PLATFORM)),)
+QT_CONFIGURE+= -platform linux-g++
+endif
+endif
+# End of workaround.
+
# Figure out what libs to install in the target
QT_LIBS=#empty
ifeq ($(BR2_PACKAGE_QT_GUI_MODULE),y)