summaryrefslogtreecommitdiff
path: root/package/qt
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-22 14:07:09 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-22 22:08:42 +0100
commit4c31d75ca447c9d27cd57233caffedef1c36ee4b (patch)
tree34926edab8b2f284d06a36f402402b72693cf50c /package/qt
parent24b27158cf103b15b3dd518bbb1b6301a3b0449d (diff)
qt: fix mysql module build
Closes #2371 Bug 2371 was a Qt compilation issue when MySQL support was enabled, because the Qt configuration tests were looking at host MySQL libraries. Even though I couldn't reproduce the bug with MySQL libraries installed on my host, there was clearly a problem since -I/usr/include/mysql and -L/usr/lib/mysql were part of the compilation flags when building those tests. This was caused by the fact that /usr/bin/mysql_config was used instead of $(STAGING_DIR)/usr/bin/mysql_config. We fix this by passing the path to the correct mysql_config script using the -mysql_config Qt ./configure argument. Since this mysql_config script returns the correct flags for libraries and headers path, the hardcoded -I and -L flag in qt.mk are no longer needed. With this in place, Qt is no longer compiled with -I/usr/include/mysql and -L/usr/lib/mysql, which presumably should fix the problem reported in bug 2371. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/qt.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 2b5b31b78..6eb31bccb 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -283,8 +283,7 @@ ifeq ($(BR2_PACKAGE_QT_IBASE),y)
QT_CONFIGURE+= -qt-sql-ibase
endif
ifeq ($(BR2_PACKAGE_QT_MYSQL),y)
-QT_CONFIGURE+= -qt-sql-mysql -I $(STAGING_DIR)/usr/include/mysql -L $(STAGING_DIR)/usr/lib/mysql
-
+QT_CONFIGURE+= -qt-sql-mysql -mysql_config $(STAGING_DIR)/usr/bin/mysql_config
QT_DEP_LIBS+=mysql_client
endif
ifeq ($(BR2_PACKAGE_QT_ODBC),y)