summaryrefslogtreecommitdiff
path: root/package/qt
diff options
context:
space:
mode:
authorMichael Roth <mroth@nessie.de>2009-10-07 11:20:26 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-09 14:35:23 +0200
commit10efac17fd7db7bd4e7eb8251fe96b45c5ca406d (patch)
tree3ab7002da4b3ee4b05b6c8343758e04ad9d0670a /package/qt
parent42325834c9ed0ea8b9e328d4eb9a54027f89e38d (diff)
qt: enable proper re-configure
The Qt configure script doesn't use config.cache but the generated Makefile provides a confclean target to properly clean out old configuration. Signed-off-by: Michael Roth <mroth@nessie.de> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/qt.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 68b4e441d..5b9906e9b 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -426,6 +426,7 @@ $(QT_TARGET_DIR)/.unpacked: $(DL_DIR)/$(QT_SOURCE)
touch $@
$(QT_TARGET_DIR)/.configured: $(QT_TARGET_DIR)/.unpacked
+ -[ -f $(QT_TARGET_DIR)/Makefile ] && $(MAKE) -C $(QT_TARGET_DIR) confclean
ifneq ($(BR2_INET_IPV6),y)
$(SED) 's/^CFG_IPV6=auto/CFG_IPV6=no/' $(QT_TARGET_DIR)/configure
$(SED) 's/^CFG_IPV6IFNAME=auto/CFG_IPV6IFNAME=no/' $(QT_TARGET_DIR)/configure
@@ -450,7 +451,7 @@ endif
# when cross compiling, Qt 4.4.3 is wrong here.
# Don't use TARGET_CONFIGURE_OPTS here, qmake would be compiled for the target
# instead of the host then.
- (cd $(QT_TARGET_DIR); rm -rf config.cache; \
+ (cd $(QT_TARGET_DIR); \
PATH=$(TARGET_PATH) \
PKG_CONFIG_SYSROOT_DIR="$(STAGING_DIR)" \
PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig:$(PKG_CONFIG_PATH)" \