summaryrefslogtreecommitdiff
path: root/package/qt
diff options
context:
space:
mode:
authorMichael Roth <mroth@nessie.de>2009-10-07 11:20:36 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-09 14:48:24 +0200
commitf9e208866bbed8a75de881b555760b095ced4011 (patch)
tree4ff22ee9f3a0151c0dc470260806a149df756372 /package/qt
parentac5d17bf65d41d8dc8e4383cc151f1901e627a25 (diff)
qt: use configure option instead a sed hack to disable xinerama
The Qt configure script gained the option '-no-xinerama' in the meantime. So use it instead hacking the script itself using sed. Signed-off-by: Michael Roth <mroth@nessie.de> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/qt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 015312e1d..a4ca3a9a1 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -406,7 +406,6 @@ ifneq ($(BR2_INET_IPV6),y)
$(SED) 's/^CFG_IPV6=auto/CFG_IPV6=no/' $(QT_TARGET_DIR)/configure
$(SED) 's/^CFG_IPV6IFNAME=auto/CFG_IPV6IFNAME=no/' $(QT_TARGET_DIR)/configure
endif
- $(SED) 's/^CFG_XINERAMA=auto/CFG_XINERAMA=no/' $(QT_TARGET_DIR)/configure
# Fix compiler path
$(call QT_QMAKE_SET,CC,$(TARGET_CC))
$(call QT_QMAKE_SET,CXX,$(TARGET_CXX))
@@ -433,6 +432,7 @@ endif
-embedded $(BR2_PACKAGE_QT_EMB_PLATFORM) \
$(QT_QCONFIG_COMMAND) \
$(QT_CONFIGURE) \
+ -no-xinerama \
-no-cups \
-no-nis \
-no-accessibility \