summaryrefslogtreecommitdiff
path: root/package/qtopia4
diff options
context:
space:
mode:
authorArnar Mar SigurĂ°sson <antab@valka.is>2008-11-02 02:16:53 +0000
committerArnar Mar SigurĂ°sson <antab@valka.is>2008-11-02 02:16:53 +0000
commit0138389b0b211312215fdd70c652d62cf6765edf (patch)
treebe882724f31e418bcb076b1fd4af1f1b6813e002 /package/qtopia4
parent057eca18342c90bb4a5cd550d7968d8019b8000b (diff)
Fixes for Qt from Markus Heidelberg
Diffstat (limited to 'package/qtopia4')
-rw-r--r--package/qtopia4/Config.gfx.in4
-rw-r--r--package/qtopia4/Config.in2
-rw-r--r--package/qtopia4/Config.mouse.in9
-rw-r--r--package/qtopia4/Config.sql.in6
-rw-r--r--package/qtopia4/qtopia4.mk17
5 files changed, 16 insertions, 22 deletions
diff --git a/package/qtopia4/Config.gfx.in b/package/qtopia4/Config.gfx.in
index 572e810a4..814788619 100644
--- a/package/qtopia4/Config.gfx.in
+++ b/package/qtopia4/Config.gfx.in
@@ -6,18 +6,14 @@ config BR2_PACKAGE_QTOPIA4_GFX_LINUXFB
config BR2_PACKAGE_QTOPIA4_GFX_TRANSFORMED
bool "Transformed"
- default n
config BR2_PACKAGE_QTOPIA4_GFX_QVFB
bool "Qt Virtual Framebuffer"
- default n
config BR2_PACKAGE_QTOPIA4_GFX_VNC
bool "VNC"
- default n
config BR2_PACKAGE_QTOPIA4_GFX_MULTISCREEN
bool "multiscreen"
- default y
endmenu
diff --git a/package/qtopia4/Config.in b/package/qtopia4/Config.in
index 1c2f94887..fb156af3d 100644
--- a/package/qtopia4/Config.in
+++ b/package/qtopia4/Config.in
@@ -185,7 +185,7 @@ choice
Select freetype2 support.
config BR2_PACKAGE_QTOPIA4_NOFREETYPE
- bool "no freetype2 support"
+ bool "no freetype2 support"
help
Do not compile in Freetype2 support.
diff --git a/package/qtopia4/Config.mouse.in b/package/qtopia4/Config.mouse.in
index 5ca4046d0..7b3946009 100644
--- a/package/qtopia4/Config.mouse.in
+++ b/package/qtopia4/Config.mouse.in
@@ -2,30 +2,23 @@ menu "Mouse drivers"
config BR2_PACKAGE_QTOPIA4_MOUSE_PC
bool "pc"
- default n
config BR2_PACKAGE_QTOPIA4_MOUSE_BUS
bool "bus"
- default n
config BR2_PACKAGE_QTOPIA4_MOUSE_LINUXTP
bool "linuxtp"
- default n
config BR2_PACKAGE_QTOPIA4_MOUSE_YOPY
bool "yopy"
- default n
config BR2_PACKAGE_QTOPIA4_MOUSE_VR41XX
- bool "vxr41xx"
- default n
+ bool "vr41xx"
config BR2_PACKAGE_QTOPIA4_MOUSE_TSLIB
bool "tslib"
- default n
config BR2_PACKAGE_QTOPIA4_MOUSE_QVFB
bool "qvfb"
- default n
endmenu
diff --git a/package/qtopia4/Config.sql.in b/package/qtopia4/Config.sql.in
index 881f7edb6..4c5f405e2 100644
--- a/package/qtopia4/Config.sql.in
+++ b/package/qtopia4/Config.sql.in
@@ -1,7 +1,7 @@
menuconfig BR2_PACKAGE_QTOPIA4_SQL_MODULE
- bool "SQL Module"
- help
- Compile Qtopia SQL Module
+ bool "SQL Module"
+ help
+ Compile Qtopia SQL Module
if BR2_PACKAGE_QTOPIA4_SQL_MODULE
config BR2_PACKAGE_QTOPIA4_MYSQL
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index cadaaa661..8b0415f25 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -95,32 +95,32 @@ endif
### Mouse drivers
ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_PC),y)
-QTOPIA4_CONFIGURE += qt-mouse-pc
+QTOPIA4_CONFIGURE += -qt-mouse-pc
else
QTOPIA4_CONFIGURE += -no-mouse-pc
endif
ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_BUS),y)
-QTOPIA4_CONFIGURE += qt-mouse-bus
+QTOPIA4_CONFIGURE += -qt-mouse-bus
else
QTOPIA4_CONFIGURE += -no-mouse-bus
endif
ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_LINUXTP),y)
-QTOPIA4_CONFIGURE += qt-mouse-linuxtp
+QTOPIA4_CONFIGURE += -qt-mouse-linuxtp
else
QTOPIA4_CONFIGURE += -no-mouse-linuxtp
endif
ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_YOPY),y)
-QTOPIA4_CONFIGURE += qt-mouse-yopy
+QTOPIA4_CONFIGURE += -qt-mouse-yopy
else
QTOPIA4_CONFIGURE += -no-mouse-yopy
endif
ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_VR41XX),y)
-QTOPIA4_CONFIGURE += qt-mouse-vr41xx
+QTOPIA4_CONFIGURE += -qt-mouse-vr41xx
else
QTOPIA4_CONFIGURE += -no-mouse-vr41xx
endif
ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_TSLIB),y)
-QTOPIA4_CONFIGURE += qt-mouse-tslib
+QTOPIA4_CONFIGURE += -qt-mouse-tslib
QTOPIA4_DEP_LIBS+=tslib
QTOPIA4_TSLIB_DEB="-D TSLIBMOUSEHANDLER_DEBUG"
QTOPIA4_TSLIB_DEB:=$(strip $(subst ",, $(QTOPIA4_TSLIB_DEB)))
@@ -128,6 +128,11 @@ QTOPIA4_TSLIB_DEB:=$(strip $(subst ",, $(QTOPIA4_TSLIB_DEB)))
else
QTOPIA4_CONFIGURE += -no-mouse-tslib
endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_QVFB),y)
+QTOPIA4_CONFIGURE += -qt-mouse-qvfb
+else
+QTOPIA4_CONFIGURE += -no-mouse-qvfb
+endif
ifeq ($(BR2_PACKAGE_QTOPIA4_DEBUG),y)
QTOPIA4_CONFIGURE+= "-debug $(QTOPIA4_TSLIB_DEB)"