summaryrefslogtreecommitdiff
path: root/package/qtopia4
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2008-11-11 18:35:43 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2008-11-11 18:35:43 +0000
commit418c84b24b4db33144ae06d436e15464efa85337 (patch)
treead3047d8f626b94ea68a01d3c18278e38b851744 /package/qtopia4
parent60d39dbb3f23fe4c18f1e384bfae9a3a861fe3da (diff)
Fix Qtopia build issues
This patch fixes two Qtopia build issues, encountered while trying to use system implementation of zlib, freetype, jpeg and libpng : * The build process doesn't look in $(STAGING_DIR)/usr/include for includes and $(STAGING_DIR)/usr/lib. Same problem as the patch currently floating around adding LDFLAGS to TARGET_CONFIGURE_OPTS, but as Qtopia doesn't use TARGET_CONFIGURE_OPTS, we need a specific fix here. So we use the -I and -L options of Qtopia's configure script. * The build process doesn't use pkg-config to get the header path for Freetype headers (located in $(STAGING_DIR)/usr/include/freetype2 and not directly in $(STAGING_DIR)/usr/include/). There was already a fix for this, consisting in adding $(FREETYPE_DIR)/include to the -I path of Qtopia's configure. This patch modifies this fix to use $(STAGING_DIR)/usr/include/freetype2 instead, which looks more coherent with how all the packages are built (using $(STAGING_DIR) as the reference to get headers and libraries). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qtopia4')
-rw-r--r--package/qtopia4/qtopia4.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index 8b0415f25..ef405285b 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -212,7 +212,7 @@ QTOPIA4_CONFIGURE+= -qt-freetype
else
ifeq ($(BR2_PACKAGE_QTOPIA4_SYSTEMFREETYPE),y)
QTOPIA4_CONFIGURE+= -system-freetype
-QTOPIA4_CONFIGURE+= -I $(FREETYPE_DIR)/include
+QTOPIA4_CONFIGURE+= -I $(STAGING_DIR)/usr/include/freetype2/
QTOPIA4_DEP_LIBS+=freetype
else
QTOPIA4_CONFIGURE+= -no-freetype
@@ -342,6 +342,8 @@ endif
-no-rpath \
-nomake examples \
-nomake demos \
+ -I $(STAGING_DIR)/usr/include \
+ -L $(STAGING_DIR)/usr/lib \
)
touch $@