summaryrefslogtreecommitdiff
path: root/package/qtopia4
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-08 18:00:54 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-08 18:00:54 +0000
commit97dabc9ab7738790e52cb8db82fa89e02cc7b6ee (patch)
tree5c4587866328f68eced816b4a72d0c93ae2f0ad3 /package/qtopia4
parentfdae8707d630a02edabdb905587a1ec6efe0ac47 (diff)
qtopia4: add kconfig option to enable Phonon
This patch adds a kconfig option to enable Phonon when configuring Qt. Phonon is the multimedia API from KDE 4 which has been integrated into Qt 4.4. For playback under Linux the GStreamer multimedia framework is used. Signed-off-by: Markus Heidelberg <markus.heidelberg@web.de> Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Diffstat (limited to 'package/qtopia4')
-rw-r--r--package/qtopia4/Config.in9
-rw-r--r--package/qtopia4/qtopia4.mk16
2 files changed, 25 insertions, 0 deletions
diff --git a/package/qtopia4/Config.in b/package/qtopia4/Config.in
index fb156af3d..2cd6e17b4 100644
--- a/package/qtopia4/Config.in
+++ b/package/qtopia4/Config.in
@@ -228,6 +228,15 @@ source "package/qtopia4/Config.sql.in"
source "package/qtopia4/Config.gfx.in"
source "package/qtopia4/Config.mouse.in"
+config BR2_PACKAGE_QTOPIA4_PHONON
+ bool "Phonon Module"
+ select BR2_PACKAGE_GSTREAMER
+ select BR2_PACKAGE_GST_PLUGINS_BASE
+ help
+ Build the Phonon module. Support for different audio/video
+ formats can be configured at the GStreamer package.
+ If unsure, say n.
+
config BR2_PACKAGE_QTOPIA4_XMLPATTERNS
bool "XML Patterns Module"
help
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index 8e2465a33..8c3e487b5 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -262,6 +262,13 @@ else
QTOPIA4_CONFIGURE+= -no-xmlpatterns
endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_PHONON),y)
+QTOPIA4_CONFIGURE+= -phonon
+QTOPIA4_DEP_LIBS+=gstreamer gst-plugins-base
+else
+QTOPIA4_CONFIGURE+= -no-phonon
+endif
+
ifeq ($(BR2_PACKAGE_QTOPIA4_SVG),y)
QTOPIA4_CONFIGURE+= -svg
else
@@ -361,6 +368,10 @@ $(TARGET_DIR)/usr/lib/libQtCore.so.4: $(STAGING_DIR)/usr/lib/libQtCore.la
ifeq ($(BR2_PACKAGE_QTOPIA4_SHARED),y)
cp -dpf $(STAGING_DIR)/usr/lib/libQt*.so.* $(TARGET_DIR)/usr/lib/
-$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libQt*.so.*
+ifeq ($(BR2_PACKAGE_QTOPIA4_PHONON),y)
+ cp -dpf $(STAGING_DIR)/usr/lib/libphonon.so.* $(TARGET_DIR)/usr/lib/
+ -$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libphonon.so.*
+endif
endif
# Install image plugins if they are built
if [ -d $(STAGING_DIR)/usr/plugins/imageformats ]; then \
@@ -368,6 +379,11 @@ endif
cp -dpfr $(STAGING_DIR)/usr/plugins/imageformats $(TARGET_DIR)/usr/plugins/; \
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/plugins/imageformats/*; \
fi
+ifeq ($(BR2_PACKAGE_QTOPIA4_PHONON),y)
+ mkdir -p $(TARGET_DIR)/usr/plugins
+ cp -dpfr $(STAGING_DIR)/usr/plugins/phonon_backend $(TARGET_DIR)/usr/plugins/
+ $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/plugins/phonon_backend/*
+endif
ifneq ($(BR2_PACKAGE_QTOPIA4_SQL_MODULE),y)
# Remove Sql libraries, not needed
-rm $(TARGET_DIR)/usr/lib/libQtSql*