summaryrefslogtreecommitdiff
path: root/package/qtopia4
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-10-29 20:40:51 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-10-29 20:40:51 +0000
commitef85a2b225bad6b79e17d4bfb758c473df54ef1c (patch)
tree2ba89e83a063625b24b9e25e7134d63c74767fb1 /package/qtopia4
parent3544d8f71e754f623d2f7c7c0fe5b10a6d88cf63 (diff)
qtopia4: fix wrong compilation of qmake
Signed-off-by: Markus Heidelberg <markus.heidelberg@web.de>
Diffstat (limited to 'package/qtopia4')
-rw-r--r--package/qtopia4/qtopia4.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index c0ced9bc4..9c08be927 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -257,8 +257,12 @@ endif
# Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.
# PKG_CONFIG_SYSROOT is only used to avoid a warning from Qt's configure system
# when cross compiling, Qt 4.4.3 is wrong here.
+# Don't use TARGET_CONFIGURE_OPTS here, qmake would be compiled for the target
+# instead of the host then.
(cd $(QTOPIA4_TARGET_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
+ PATH=$(TARGET_PATH) \
+ PKG_CONFIG_SYSROOT_DIR="$(STAGING_DIR)" \
+ PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig:$(PKG_CONFIG_PATH)" \
PKG_CONFIG_SYSROOT="$(STAGING_DIR)" \
./configure \
-verbose \