summaryrefslogtreecommitdiff
path: root/package/squashfs3/squashfs3.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-07 21:23:31 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-07 21:32:02 +0200
commitf6c18b97caeeae18ab2d8d19409183c6c905ec94 (patch)
tree40e6fd58467d94a12240f6e98e1ff87a188bb862 /package/squashfs3/squashfs3.mk
parentd5a1757565c0c5539e2728c23d9cb955fba02615 (diff)
squashfs3: fix build when zlib isn't available on the host
We need to pass CFLAGS and LDFLAGS, and to rename the patch so that it actually gets applied. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/squashfs3/squashfs3.mk')
-rw-r--r--package/squashfs3/squashfs3.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/squashfs3/squashfs3.mk b/package/squashfs3/squashfs3.mk
index 5504b1426..69aab1489 100644
--- a/package/squashfs3/squashfs3.mk
+++ b/package/squashfs3/squashfs3.mk
@@ -18,7 +18,7 @@ define SQUASHFS3_INSTALL_TARGET_CMDS
endef
define HOST_SQUASHFS3_BUILD_CMDS
- $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/squashfs-tools/
+ $(HOST_MAKE_ENV) $(MAKE) CFLAGS="$(HOST_CFLAGS)" LDFLAGS="$(HOST_LDFLAGS)" -C $(@D)/squashfs-tools/
endef
define HOST_SQUASHFS3_INSTALL_CMDS