summaryrefslogtreecommitdiff
path: root/package/sysprof/Config.in
diff options
context:
space:
mode:
authorWill Newton <will.newton@gmail.com>2012-07-27 16:26:23 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-30 23:50:11 +0200
commit58a62766a1869c913845a649890855515aebb016 (patch)
tree8c91584c07e5216a3179edeb6185cfe99d538a51 /package/sysprof/Config.in
parente61153cf972e1f060bc0905df61381a9548cb16e (diff)
sysprof: New package.
[thomas.petazzoni@free-electrons.com: - add dependencies on the supported architectures to avoid build failures on ARM and other unsupported arches - add a patch that removes an useless warning about the kernel version. This patch is present upstream. However since it modifies configure.ac, we need to autoreconf the package.] Signed-off-by: Will Newton <will.newton@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sysprof/Config.in')
-rw-r--r--package/sysprof/Config.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/sysprof/Config.in b/package/sysprof/Config.in
new file mode 100644
index 000000000..513a32cd5
--- /dev/null
+++ b/package/sysprof/Config.in
@@ -0,0 +1,24 @@
+config BR2_PACKAGE_SYSPROF
+ bool "sysprof"
+ select BR2_PACKAGE_LIBGLIB2
+ depends on BR2_USE_WCHAR # glib2
+ # In its util.h file, sysprof contains architecture-specific
+ # code
+ depends on BR2_i386 || BR2_x86_64 || BR2_powerpc || BR2_sh4a || BR2_sh4aeb
+ help
+ Sysprof is a statistical, system-wide profiler that can
+ profile user and kernel code using the perf API.
+
+ http://sysprof.com
+
+config BR2_PACKAGE_SYSPROF_GUI
+ bool "sysprof GUI"
+ depends on BR2_PACKAGE_SYSPROF
+ depends on BR2_PACKAGE_LIBGTK2
+ select BR2_PACKAGE_LIBGLADE
+ select BR2_PACKAGE_GDK_PIXBUF
+ help
+ GUI for the sysprof system-wide statistical profiler.
+
+comment "sysprof requires a toolchain with WCHAR support"
+ depends on !BR2_USE_WCHAR