summaryrefslogtreecommitdiff
path: root/package/uboot-tools/uboot-tools-2012.04.01-hostcflags-override-fix.patch
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-04-27 05:05:08 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-29 11:00:24 +0200
commit8952fad3ee43dc16f00fc3b5b3584139cbd30385 (patch)
tree51caeedf51147598f5830b1f3cf94694f798e8d8 /package/uboot-tools/uboot-tools-2012.04.01-hostcflags-override-fix.patch
parent0b385d88689e8089df528a621b92851fb6dead27 (diff)
uboot-tools: bump to version 2012.04.01
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/uboot-tools/uboot-tools-2012.04.01-hostcflags-override-fix.patch')
-rw-r--r--package/uboot-tools/uboot-tools-2012.04.01-hostcflags-override-fix.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/uboot-tools/uboot-tools-2012.04.01-hostcflags-override-fix.patch b/package/uboot-tools/uboot-tools-2012.04.01-hostcflags-override-fix.patch
new file mode 100644
index 000000000..0202eda9b
--- /dev/null
+++ b/package/uboot-tools/uboot-tools-2012.04.01-hostcflags-override-fix.patch
@@ -0,0 +1,29 @@
+[PATCH] Fix tools build with custom HOSTCFLAGS
+
+We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
+overridden on the cmdline.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ config.mk | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+Index: u-boot-2011.03/config.mk
+===================================================================
+--- u-boot-2011.03.orig/config.mk
++++ u-boot-2011.03/config.mk
+@@ -46,10 +46,12 @@
+
+ #########################################################################
+
+-HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
+- $(HOSTCPPFLAGS)
++HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
+ HOSTSTRIP = strip
+
++# append CPPFLAGS even if CFLAGS has been overridden on cmdline
++override HOSTCFLAGS += $(HOSTCPPFLAGS)
++
+ #
+ # Mac OS X / Darwin's C preprocessor is Apple specific. It
+ # generates numerous errors and warnings. We want to bypass it