summaryrefslogtreecommitdiff
path: root/package/uboot-tools/uboot-tools-2012.07-hostcflags-override-fix.patch
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-09-04 03:55:23 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-20 22:26:46 +0200
commit47a7a2771a728a1e89b8ea70d610c3670e783bf3 (patch)
tree87b9a8566794a9b38ff75265f4cca81550a387cc /package/uboot-tools/uboot-tools-2012.07-hostcflags-override-fix.patch
parent218497de42c8f3205ea631ad7250d2b61d30b2f9 (diff)
u-boot: add version 2012.07
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/uboot-tools/uboot-tools-2012.07-hostcflags-override-fix.patch')
-rw-r--r--package/uboot-tools/uboot-tools-2012.07-hostcflags-override-fix.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/uboot-tools/uboot-tools-2012.07-hostcflags-override-fix.patch b/package/uboot-tools/uboot-tools-2012.07-hostcflags-override-fix.patch
new file mode 100644
index 000000000..0202eda9b
--- /dev/null
+++ b/package/uboot-tools/uboot-tools-2012.07-hostcflags-override-fix.patch
@@ -0,0 +1,29 @@
+[PATCH] Fix tools build with custom HOSTCFLAGS
+
+We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
+overridden on the cmdline.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ config.mk | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+Index: u-boot-2011.03/config.mk
+===================================================================
+--- u-boot-2011.03.orig/config.mk
++++ u-boot-2011.03/config.mk
+@@ -46,10 +46,12 @@
+
+ #########################################################################
+
+-HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
+- $(HOSTCPPFLAGS)
++HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
+ HOSTSTRIP = strip
+
++# append CPPFLAGS even if CFLAGS has been overridden on cmdline
++override HOSTCFLAGS += $(HOSTCPPFLAGS)
++
+ #
+ # Mac OS X / Darwin's C preprocessor is Apple specific. It
+ # generates numerous errors and warnings. We want to bypass it