summaryrefslogtreecommitdiff
path: root/package/util-linux
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-12-27 21:49:53 +0000
committerEric Andersen <andersen@codepoet.org>2004-12-27 21:49:53 +0000
commitb5a211c68eb8f6a5c00910eb96c5339c37df65ab (patch)
tree7f13e7b73ffcf8604c9ef817fe0b59e2204d8ee8 /package/util-linux
parent3d7a187f7690d3d42f59f933f5d4aa32c096b7b4 (diff)
When both busybox and coreutils and/or util-linux are selected,
make certain that it is coreutils and/or util-linux that actually gets their utilities installed. -Erik
Diffstat (limited to 'package/util-linux')
-rw-r--r--package/util-linux/util-linux.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index fd0b7240f..8cdce9690 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -60,7 +60,14 @@ $(UTIL-LINUX_TARGET_BINARY): $(UTIL-LINUX_BINARY)
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/share/info \
$(TARGET_DIR)/usr/share/man $(TARGET_DIR)/usr/share/doc
+#If both util-linux and busybox are selected, make certain util-linux
+#wins the fight over who gets to have their utils actually installed
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+util-linux: uclibc busybox $(UTIL-LINUX_TARGET_BINARY)
+else
util-linux: uclibc $(UTIL-LINUX_TARGET_BINARY)
+endif
+
util-linux-source: $(DL_DIR)/$(UTIL-LINUX_SOURCE)