summaryrefslogtreecommitdiff
path: root/package/x11r7/libxcb
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
committerEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
commita7e49eb2af5d2ca6e53fb908fddfddd92696910a (patch)
treeef6625168d47591f85f98a2014f61bc697cf2427 /package/x11r7/libxcb
parent7aa1c59ebf82bd91a9e2b03178ceb4ce4fbf1b9d (diff)
Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn't
quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
Diffstat (limited to 'package/x11r7/libxcb')
-rw-r--r--package/x11r7/libxcb/Config.in15
-rw-r--r--package/x11r7/libxcb/libxcb-1.0-xcbproto-xml-dir.patch11
-rw-r--r--package/x11r7/libxcb/libxcb.mk17
3 files changed, 43 insertions, 0 deletions
diff --git a/package/x11r7/libxcb/Config.in b/package/x11r7/libxcb/Config.in
new file mode 100644
index 000000000..8f7d38494
--- /dev/null
+++ b/package/x11r7/libxcb/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_LIBXCB
+ bool "libxcb"
+ default n
+ select BR2_PACKAGE_PTHREAD_STUBS
+ select BR2_PACKAGE_XCB_PROTO
+ select BR2_PACKAGE_XLIB_LIBXDMCP
+ select BR2_PACKAGE_XLIB_LIBXAU
+ help
+ The X protocol C-language Binding (XCB) is a replacement for
+ Xlib featuring a small footprint, latency hiding, direct access
+ to the protocol, improved threading support, and extensibility.
+
+ http://xcb.freedesktop.org/
+
+
diff --git a/package/x11r7/libxcb/libxcb-1.0-xcbproto-xml-dir.patch b/package/x11r7/libxcb/libxcb-1.0-xcbproto-xml-dir.patch
new file mode 100644
index 000000000..5159459ff
--- /dev/null
+++ b/package/x11r7/libxcb/libxcb-1.0-xcbproto-xml-dir.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac.orig 2007-06-04 12:56:16.000000000 +0200
++++ a/configure.ac 2007-06-04 12:55:58.000000000 +0200
+@@ -50,7 +50,7 @@
+
+ # Find the xcb-proto protocol descriptions
+ AC_MSG_CHECKING(XCBPROTO_XCBINCLUDEDIR)
+-XCBPROTO_XCBINCLUDEDIR=`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
++XCBPROTO_XCBINCLUDEDIR=$STAGING_DIR`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
+ AC_MSG_RESULT($XCBPROTO_XCBINCLUDEDIR)
+ AC_SUBST(XCBPROTO_XCBINCLUDEDIR)
+
diff --git a/package/x11r7/libxcb/libxcb.mk b/package/x11r7/libxcb/libxcb.mk
new file mode 100644
index 000000000..24469329e
--- /dev/null
+++ b/package/x11r7/libxcb/libxcb.mk
@@ -0,0 +1,17 @@
+#############################################################
+#
+# libxcb
+#
+#############################################################
+LIBXCB_VERSION = 1.0
+LIBXCB_SOURCE = libxcb-$(LIBXCB_VERSION).tar.bz2
+LIBXCB_SITE = http://xcb.freedesktop.org/dist/
+
+LIBXCB_INSTALL_STAGING = YES
+
+LIBXCB_AUTORECONF = YES
+LIBXCB_DEPENDANCIES = pthread-stubs xcb-proto xlib_libXdmcp xlib_libXau
+LIBXCB_CONF_ENV = STAGING_DIR="$(STAGING_DIR)"
+
+$(eval $(call AUTOTARGETS,libxcb))
+