summaryrefslogtreecommitdiff
path: root/package/x11r7/libxcb
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-22 15:37:16 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-27 22:48:14 +0200
commitee363f5231462014fa21350514a1d7613f39ae88 (patch)
treeacf4255f5990669cf76547d9e1ec4c11d0a3b97b /package/x11r7/libxcb
parent6f5188120b3ca1e7ca34848e34969710a411a5a7 (diff)
xkeyboard-config: add dependency on host-xapp_xkbcomp
In order to get xkeyboard-config to build, it needs xkbcomp to be built on the host, i.e host-xapp_xkbcomp. In turn, xapp_xkbcomp needs xlib_libX11 and xlib_libxkbfile, which in turn need a few libraries. This commit adds all the relevant dependencies to build everything that is needed to get xkeyboard-config to build correctly. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/x11r7/libxcb')
-rw-r--r--package/x11r7/libxcb/libxcb.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/x11r7/libxcb/libxcb.mk b/package/x11r7/libxcb/libxcb.mk
index 4f9b3233c..bfeceab44 100644
--- a/package/x11r7/libxcb/libxcb.mk
+++ b/package/x11r7/libxcb/libxcb.mk
@@ -16,5 +16,8 @@ LIBXCB_CONF_ENV = STAGING_DIR="$(STAGING_DIR)"
HOST_PYTHON_VERSION=$(shell python --version 2>&1 | sed 's/Python \([0-9]\.[^\.]\).*/\1/')
LIBXCB_MAKE_OPT = XCBPROTO_XCBINCLUDEDIR=$(STAGING_DIR)/usr/share/xcb XCBPROTO_XCBPYTHONDIR=$(STAGING_DIR)/usr/lib/python$(HOST_PYTHON_VERSION)/site-packages
+HOST_LIBXCB_DEPENDENCIES = host-libxslt host-pthread-stubs host-xcb-proto host-xlib_libXdmcp host-xlib_libXau
+
$(eval $(call AUTOTARGETS,package/x11r7,libxcb))
+$(eval $(call AUTOTARGETS,package/x11r7,libxcb,host))