summaryrefslogtreecommitdiff
path: root/package/x11r7/mcookie
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-29 21:57:50 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-30 08:26:07 +0200
commit190700ab034670084fd71f80a42a664ade2130a8 (patch)
tree6f6ab36825e4c3b810a688c8d19e585819936c27 /package/x11r7/mcookie
parent4ad5533832eba4bf386b81d33ecaaf92a4a145fe (diff)
mcookie: convert to the GENTARGETS infrastructure
[Peter: fix missing newline at eof] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/x11r7/mcookie')
-rw-r--r--package/x11r7/mcookie/mcookie.mk24
1 files changed, 13 insertions, 11 deletions
diff --git a/package/x11r7/mcookie/mcookie.mk b/package/x11r7/mcookie/mcookie.mk
index 12ef47579..030dd74b2 100644
--- a/package/x11r7/mcookie/mcookie.mk
+++ b/package/x11r7/mcookie/mcookie.mk
@@ -4,17 +4,19 @@
#
#############################################################
-$(TARGET_DIR)/usr/bin/mcookie: package/x11r7/mcookie/mcookie.c
- $(TARGET_CC) -Wall -Os -s package/x11r7/mcookie/mcookie.c -o $(TARGET_DIR)/usr/bin/mcookie
+# Source included in Buildroot
+MCOOKIE_SOURCE =
+define MCOOKIE_EXTRACT_CMDS
+ cp package/x11r7/mcookie/mcookie.c $(@D)/
+endef
-mcookie: $(TARGET_DIR)/usr/bin/mcookie
+define MCOOKIE_BUILD_CMDS
+ (cd $(@D); $(TARGET_CC) -Wall -Os -s mcookie.c -o mcookie)
+endef
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_MCOOKIE),y)
-TARGETS+=mcookie
-endif
+define MCOOKIE_INSTALL_TARGET_CMDS
+ install -m 0755 -D $(@D)/mcookie $(TARGET_DIR)/usr/bin/mcookie
+endef
+
+$(eval $(call GENTARGETS))