summaryrefslogtreecommitdiff
path: root/package/x11r7/pthread-stubs
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
committerEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
commita7e49eb2af5d2ca6e53fb908fddfddd92696910a (patch)
treeef6625168d47591f85f98a2014f61bc697cf2427 /package/x11r7/pthread-stubs
parent7aa1c59ebf82bd91a9e2b03178ceb4ce4fbf1b9d (diff)
Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn't
quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
Diffstat (limited to 'package/x11r7/pthread-stubs')
-rw-r--r--package/x11r7/pthread-stubs/Config.in9
-rw-r--r--package/x11r7/pthread-stubs/pthread-stubs.mk14
2 files changed, 23 insertions, 0 deletions
diff --git a/package/x11r7/pthread-stubs/Config.in b/package/x11r7/pthread-stubs/Config.in
new file mode 100644
index 000000000..4215a4870
--- /dev/null
+++ b/package/x11r7/pthread-stubs/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PTHREAD_STUBS
+ bool "pthread-stubs"
+ default n
+ help
+ This library provides weak aliases for pthread functions not
+ provided in libc or otherwise available by default.
+
+ http://xcb.freedesktop.org/
+
diff --git a/package/x11r7/pthread-stubs/pthread-stubs.mk b/package/x11r7/pthread-stubs/pthread-stubs.mk
new file mode 100644
index 000000000..90bb6cfa1
--- /dev/null
+++ b/package/x11r7/pthread-stubs/pthread-stubs.mk
@@ -0,0 +1,14 @@
+#############################################################
+#
+# pthread-stubs
+#
+#############################################################
+PTHREAD_STUBS_VERSION = 0.1
+PTHREAD_STUBS_SOURCE = libpthread-stubs-$(PTHREAD_STUBS_VERSION).tar.bz2
+PTHREAD_STUBS_SITE = http://xcb.freedesktop.org/dist/
+
+PTHREAD_STUBS_DEPENDANCIES = uclibc
+PTHREAD_STUBS_INSTALL_STAGING = YES
+
+$(eval $(call AUTOTARGETS,pthread-stubs))
+