summaryrefslogtreecommitdiff
path: root/package/x11r7/xapp_xdm
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
committerEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
commita7e49eb2af5d2ca6e53fb908fddfddd92696910a (patch)
treeef6625168d47591f85f98a2014f61bc697cf2427 /package/x11r7/xapp_xdm
parent7aa1c59ebf82bd91a9e2b03178ceb4ce4fbf1b9d (diff)
Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn't
quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
Diffstat (limited to 'package/x11r7/xapp_xdm')
-rw-r--r--package/x11r7/xapp_xdm/Config.in16
-rw-r--r--package/x11r7/xapp_xdm/xapp_xdm-1.1.3-urandom.patch15
-rw-r--r--package/x11r7/xapp_xdm/xapp_xdm.mk13
3 files changed, 44 insertions, 0 deletions
diff --git a/package/x11r7/xapp_xdm/Config.in b/package/x11r7/xapp_xdm/Config.in
new file mode 100644
index 000000000..0726fb5de
--- /dev/null
+++ b/package/x11r7/xapp_xdm/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_XAPP_XDM
+ bool "xdm"
+ default n
+ select BR2_PACKAGE_XAPP_XINIT
+ select BR2_PACKAGE_XAPP_SESSREG
+ select BR2_PACKAGE_XAPP_XRDB
+ select BR2_PACKAGE_XLIB_LIBX11
+ select BR2_PACKAGE_XLIB_LIBXAW
+ select BR2_PACKAGE_XLIB_LIBXDMCP
+ select BR2_PACKAGE_XLIB_LIBXINERAMA
+ select BR2_PACKAGE_XLIB_LIBXT
+ select BR2_PACKAGE_XPROTO_XINERAMAPROTO
+ select BR2_PACKAGE_XPROTO_XPROTO
+ help
+ xdm 1.1.3
+ X.Org xdm application
diff --git a/package/x11r7/xapp_xdm/xapp_xdm-1.1.3-urandom.patch b/package/x11r7/xapp_xdm/xapp_xdm-1.1.3-urandom.patch
new file mode 100644
index 000000000..ed51d8f81
--- /dev/null
+++ b/package/x11r7/xapp_xdm/xapp_xdm-1.1.3-urandom.patch
@@ -0,0 +1,15 @@
+--- xdm-1.1.3/configure.ac.orig 2007-06-10 15:34:10.000000000 +0200
++++ xdm-1.1.3/configure.ac 2007-06-10 15:38:33.000000000 +0200
+@@ -152,8 +152,12 @@
+ RANDOM_DEVICE="$withval", RANDOM_DEVICE="try")
+
+ if test x$RANDOM_DEVICE = xyes -o x$RANDOM_DEVICE = xtry ; then
++ if test "$cross_compiling" = "no" ; then
+ AC_CHECK_FILE([/dev/urandom], [RANDOM_DEVICE=/dev/urandom],
+ AC_CHECK_FILE([/dev/random], [RANDOM_DEVICE=/dev/random]))
++ else
++ RANDOM_DEVICE=/dev/urandom
++ fi
+ if test x$RANDOM_DEVICE = xyes ; then
+ AC_MSG_ERROR(["random device support requested, but no random device was found."])
+ else
diff --git a/package/x11r7/xapp_xdm/xapp_xdm.mk b/package/x11r7/xapp_xdm/xapp_xdm.mk
new file mode 100644
index 000000000..db8532743
--- /dev/null
+++ b/package/x11r7/xapp_xdm/xapp_xdm.mk
@@ -0,0 +1,13 @@
+################################################################################
+#
+# xapp_xdm -- X.Org xdm application
+#
+################################################################################
+
+XAPP_XDM_VERSION = 1.1.3
+XAPP_XDM_SOURCE = xdm-$(XAPP_XDM_VERSION).tar.bz2
+XAPP_XDM_SITE = http://xorg.freedesktop.org/releases/individual/app
+XAPP_XDM_AUTORECONF = YES
+XAPP_XDM_DEPENDANCIES = xapp_xinit xapp_sessreg xapp_xrdb xlib_libX11 xlib_libXaw xlib_libXdmcp xlib_libXinerama xlib_libXt xproto_xineramaproto xproto_xproto
+
+$(eval $(call AUTOTARGETS,xapp_xdm))