summaryrefslogtreecommitdiff
path: root/package/x11r7/xlib_libX11/xlib_libX11.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
committerEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
commita7e49eb2af5d2ca6e53fb908fddfddd92696910a (patch)
treeef6625168d47591f85f98a2014f61bc697cf2427 /package/x11r7/xlib_libX11/xlib_libX11.mk
parent7aa1c59ebf82bd91a9e2b03178ceb4ce4fbf1b9d (diff)
Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn't
quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
Diffstat (limited to 'package/x11r7/xlib_libX11/xlib_libX11.mk')
-rw-r--r--package/x11r7/xlib_libX11/xlib_libX11.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/x11r7/xlib_libX11/xlib_libX11.mk b/package/x11r7/xlib_libX11/xlib_libX11.mk
new file mode 100644
index 000000000..0e458ed59
--- /dev/null
+++ b/package/x11r7/xlib_libX11/xlib_libX11.mk
@@ -0,0 +1,16 @@
+################################################################################
+#
+# xlib_libX11 -- X.Org X11 library
+#
+################################################################################
+
+XLIB_LIBX11_VERSION = 1.1.1
+XLIB_LIBX11_SOURCE = libX11-$(XLIB_LIBX11_VERSION).tar.bz2
+XLIB_LIBX11_SITE = http://xorg.freedesktop.org/releases/individual/lib
+XLIB_LIBX11_AUTORECONF = YES
+XLIB_LIBX11_INSTALL_STAGING = YES
+XLIB_LIBX11_DEPENDANCIES = libxcb xutil_util-macros xlib_xtrans xlib_libXau xlib_libXdmcp xproto_kbproto xproto_xproto xproto_xextproto xproto_inputproto xproto_xf86bigfontproto xproto_bigreqsproto xproto_xcmiscproto
+XLIB_LIBX11_CONF_ENV = ac_cv_func_mmap_fixed_mapped=yes CC_FOR_BUILD="/usr/bin/gcc -I$(STAGING_DIR)/usr/include"
+XLIB_LIBX11_CONF_OPT = --disable-malloc0returnsnull --with-xcb --enable-shared --disable-static
+
+$(eval $(call AUTOTARGETS,xlib_libX11))