summaryrefslogtreecommitdiff
path: root/package/x11r7/xlib_libXaw
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
committerEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
commita7e49eb2af5d2ca6e53fb908fddfddd92696910a (patch)
treeef6625168d47591f85f98a2014f61bc697cf2427 /package/x11r7/xlib_libXaw
parent7aa1c59ebf82bd91a9e2b03178ceb4ce4fbf1b9d (diff)
Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn't
quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
Diffstat (limited to 'package/x11r7/xlib_libXaw')
-rw-r--r--package/x11r7/xlib_libXaw/Config.in12
-rw-r--r--package/x11r7/xlib_libXaw/xlib_libXaw.mk15
2 files changed, 27 insertions, 0 deletions
diff --git a/package/x11r7/xlib_libXaw/Config.in b/package/x11r7/xlib_libXaw/Config.in
new file mode 100644
index 000000000..47efd8335
--- /dev/null
+++ b/package/x11r7/xlib_libXaw/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_XLIB_LIBXAW
+ bool "libXaw"
+ default n
+ select BR2_PACKAGE_XLIB_LIBX11
+ select BR2_PACKAGE_XLIB_LIBXT
+ select BR2_PACKAGE_XLIB_LIBXMU
+ select BR2_PACKAGE_XLIB_LIBXPM
+ select BR2_PACKAGE_XPROTO_XPROTO
+ select BR2_PACKAGE_XLIB_LIBXP
+ help
+ libXaw 1.0.2
+ X.Org Xaw library
diff --git a/package/x11r7/xlib_libXaw/xlib_libXaw.mk b/package/x11r7/xlib_libXaw/xlib_libXaw.mk
new file mode 100644
index 000000000..6eacaa761
--- /dev/null
+++ b/package/x11r7/xlib_libXaw/xlib_libXaw.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# xlib_libXaw -- X.Org Xaw library
+#
+################################################################################
+
+XLIB_LIBXAW_VERSION = 1.0.2
+XLIB_LIBXAW_SOURCE = libXaw-$(XLIB_LIBXAW_VERSION).tar.bz2
+XLIB_LIBXAW_SITE = http://xorg.freedesktop.org/releases/individual/lib
+XLIB_LIBXAW_AUTORECONF = YES
+XLIB_LIBXAW_INSTALL_STAGING = YES
+XLIB_LIBXAW_DEPENDANCIES = xlib_libX11 xlib_libXt xlib_libXmu xlib_libXpm xproto_xproto xlib_libXp
+XLIB_LIBXAW_CONF_OPT = --enable-shared --disable-static
+
+$(eval $(call AUTOTARGETS,xlib_libXaw))