summaryrefslogtreecommitdiff
path: root/package/x11r7/xlib_libXp
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
committerEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
commita7e49eb2af5d2ca6e53fb908fddfddd92696910a (patch)
treeef6625168d47591f85f98a2014f61bc697cf2427 /package/x11r7/xlib_libXp
parent7aa1c59ebf82bd91a9e2b03178ceb4ce4fbf1b9d (diff)
Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn't
quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
Diffstat (limited to 'package/x11r7/xlib_libXp')
-rw-r--r--package/x11r7/xlib_libXp/Config.in10
-rw-r--r--package/x11r7/xlib_libXp/xlib_libXp.mk15
2 files changed, 25 insertions, 0 deletions
diff --git a/package/x11r7/xlib_libXp/Config.in b/package/x11r7/xlib_libXp/Config.in
new file mode 100644
index 000000000..7b7dd1807
--- /dev/null
+++ b/package/x11r7/xlib_libXp/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_XLIB_LIBXP
+ bool "libXp"
+ default n
+ select BR2_PACKAGE_XLIB_LIBX11
+ select BR2_PACKAGE_XLIB_LIBXAU
+ select BR2_PACKAGE_XLIB_LIBXEXT
+ select BR2_PACKAGE_XPROTO_PRINTPROTO
+ help
+ libXp 1.0.0
+ X.Org Xp library
diff --git a/package/x11r7/xlib_libXp/xlib_libXp.mk b/package/x11r7/xlib_libXp/xlib_libXp.mk
new file mode 100644
index 000000000..38cae343d
--- /dev/null
+++ b/package/x11r7/xlib_libXp/xlib_libXp.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# xlib_libXp -- X.Org Xp library
+#
+################################################################################
+
+XLIB_LIBXP_VERSION = 1.0.0
+XLIB_LIBXP_SOURCE = libXp-$(XLIB_LIBXP_VERSION).tar.bz2
+XLIB_LIBXP_SITE = http://xorg.freedesktop.org/releases/individual/lib
+XLIB_LIBXP_AUTORECONF = YES
+XLIB_LIBXP_INSTALL_STAGING = YES
+XLIB_LIBXP_DEPENDANCIES = xlib_libX11 xlib_libXau xlib_libXext xproto_printproto
+XLIB_LIBXP_CONF_OPT = --disable-malloc0returnsnull --enable-shared --disable-static
+
+$(eval $(call AUTOTARGETS,xlib_libXp))