summaryrefslogtreecommitdiff
path: root/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
diff options
context:
space:
mode:
authorWill Wagner <will_wagner@carallon.com>2010-04-14 18:06:40 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-04-22 12:26:09 +0200
commit09729b5e63b0659a434b28d9b82bc892c017dfa4 (patch)
tree1e2a2be56d469c17781b0d37206eba5670ecae38 /package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
parentab0a176febabb9762ee0c9c04eac1ed45cb74947 (diff)
xserver_xorg-server: bump version, improve option support
Later version of xserver no longer need configure hack to say where mesa3d is located. Signed-off-by: Will Wagner <will_wagner@carallon.com> Acked-by: Paulius Zaleckas <paulius.zaleckas@gmail.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/x11r7/xserver_xorg-server/xserver_xorg-server.mk')
-rw-r--r--package/x11r7/xserver_xorg-server/xserver_xorg-server.mk41
1 files changed, 23 insertions, 18 deletions
diff --git a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
index 950c2ca23..0dd6127f0 100644
--- a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
+++ b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
@@ -4,7 +4,7 @@
#
################################################################################
-XSERVER_XORG_SERVER_VERSION = 1.7.1
+XSERVER_XORG_SERVER_VERSION = 1.7.5
XSERVER_XORG_SERVER_SOURCE = xorg-server-$(XSERVER_XORG_SERVER_VERSION).tar.bz2
XSERVER_XORG_SERVER_SITE = http://xorg.freedesktop.org/releases/individual/xserver
XSERVER_XORG_SERVER_AUTORECONF = NO
@@ -15,11 +15,11 @@ XSERVER_XORG_SERVER_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install install
XSERVER_XORG_SERVER_DEPENDENCIES = \
xutil_util-macros \
+ xlib_libpciaccess \
xlib_libXfont \
xlib_libX11 \
xlib_libXau \
xlib_libXdmcp \
- xlib_libXScrnSaver \
xlib_libXext \
xlib_libXfixes \
xlib_libXi \
@@ -30,7 +30,6 @@ XSERVER_XORG_SERVER_DEPENDENCIES = \
xlib_libXinerama \
xlib_libXrandr \
xlib_libXdamage \
- xlib_libXxf86misc \
xlib_libXxf86vm \
xlib_libxkbfile \
xlib_xtrans \
@@ -38,7 +37,6 @@ XSERVER_XORG_SERVER_DEPENDENCIES = \
xproto_bigreqsproto \
xproto_compositeproto \
xproto_damageproto \
- xproto_evieext \
xproto_fixesproto \
xproto_fontsproto \
xproto_glproto \
@@ -53,7 +51,6 @@ XSERVER_XORG_SERVER_DEPENDENCIES = \
xproto_xf86bigfontproto \
xproto_xf86dgaproto \
xproto_xf86driproto \
- xproto_xf86miscproto \
xproto_xf86rushproto \
xproto_xf86vidmodeproto \
xproto_xproto \
@@ -69,7 +66,7 @@ XSERVER_XORG_SERVER_CONF_OPT = --disable-config-hal \
ifeq ($(BR2_PACKAGE_XSERVER_xorg),y)
XSERVER_XORG_SERVER_DEPENDENCIES += mesa3d
-XSERVER_XORG_SERVER_CONF_OPT += --with-mesa-source="$(BUILD_DIR)/Mesa-$(MESA3D_VERSION)" --enable-xorg
+XSERVER_XORG_SERVER_CONF_OPT += --enable-xorg --disable-glx
else
XSERVER_XORG_SERVER_CONF_OPT += --disable-xorg
endif
@@ -86,12 +83,6 @@ else
XSERVER_XORG_SERVER_CONF_OPT += --disable-null-root-cursor
endif
-ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_BUILTIN_FONTS),y)
-XSERVER_XORG_SERVER_CONF_OPT += --enable-builtin-fonts
-else
-XSERVER_XORG_SERVER_CONF_OPT += --disable-builtin-fonts
-endif
-
ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_AIGLX),y)
XSERVER_XORG_SERVER_CONF_OPT += --enable-aiglx
else
@@ -111,12 +102,6 @@ endif
ifeq ($(BR2_PACKAGE_FREETYPE),y)
XSERVER_XORG_SERVER_DEPENDENCIES += freetype
-XSERVER_XORG_SERVER_CONF_OPT += --enable-freetype
-endif
-
-ifeq ($(BR2_PACKAGE_XPROTO_TRAPPROTO),y)
-XSERVER_XORG_SERVER_DEPENDENCIES += xproto_trapproto
-XSERVER_XORG_SERVER_CONF_OPT += --enable-xtrap
endif
ifeq ($(BR2_PACKAGE_XPROTO_RECORDPROTO),y)
@@ -124,9 +109,29 @@ XSERVER_XORG_SERVER_DEPENDENCIES += xproto_recordproto
XSERVER_XORG_SERVER_CONF_OPT += --enable-record
endif
+ifneq ($(BR2_PACKAGE_XLIB_LIBXVMC),y)
+XSERVER_XORG_SERVER_CONF_OPT += --disable-xvmc
+endif
+
+ifneq ($(BR2_PACKAGE_XLIB_LIBXCOMPOSITE),y)
+XSERVER_XORG_SERVER_CONF_OPT += --disable-composite
+endif
+
ifeq ($(BR2_PACKAGE_XPROTO_DRI2PROTO),y)
XSERVER_XORG_SERVER_DEPENDENCIES += xproto_dri2proto
XSERVER_XORG_SERVER_CONF_OPT += --enable-dri2
endif
+ifeq ($(BR2_PACKAGE_XLIB_LIBXSCRNSAVER),y)
+XSERVER_XORG_SERVER_DEPENDENCIES += xlib_libXScrnSaver
+XSERVER_XORG_SERVER_CONF_OPT += --enable-screensaver
+else
+XSERVER_XORG_SERVER_CONF_OPT += --disable-screensaver
+endif
+
+ifneq ($(BR2_PACKAGE_XLIB_LIBDMX),y)
+XSERVER_XORG_SERVER_CONF_OPT += --disable-dmx
+endif
+
+
$(eval $(call AUTOTARGETS,package/x11r7,xserver_xorg-server))