summaryrefslogtreecommitdiff
path: root/package/x11r7/xserver_xorg-server
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
committerEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
commita7e49eb2af5d2ca6e53fb908fddfddd92696910a (patch)
treeef6625168d47591f85f98a2014f61bc697cf2427 /package/x11r7/xserver_xorg-server
parent7aa1c59ebf82bd91a9e2b03178ceb4ce4fbf1b9d (diff)
Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn't
quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
Diffstat (limited to 'package/x11r7/xserver_xorg-server')
-rw-r--r--package/x11r7/xserver_xorg-server/Config.in52
-rw-r--r--package/x11r7/xserver_xorg-server/xserver_xorg-server-1.2.0-xf86ScanPci-no-optimize.patch10
-rw-r--r--package/x11r7/xserver_xorg-server/xserver_xorg-server.mk15
3 files changed, 77 insertions, 0 deletions
diff --git a/package/x11r7/xserver_xorg-server/Config.in b/package/x11r7/xserver_xorg-server/Config.in
new file mode 100644
index 000000000..4961aded4
--- /dev/null
+++ b/package/x11r7/xserver_xorg-server/Config.in
@@ -0,0 +1,52 @@
+config BR2_PACKAGE_XSERVER_XORG_SERVER
+ bool "xorg-server"
+ default n
+ select BR2_PACKAGE_XLIB_LIBXFONT
+ select BR2_PACKAGE_LIBDRM
+ select BR2_PACKAGE_XLIB_LIBXKBUI
+ select BR2_PACKAGE_XPROTO_COMPOSITEPROTO
+ select BR2_PACKAGE_XPROTO_DAMAGEPROTO
+ select BR2_PACKAGE_XPROTO_FIXESPROTO
+ select BR2_PACKAGE_XPROTO_GLPROTO
+ select BR2_PACKAGE_XPROTO_KBPROTO
+ select BR2_PACKAGE_XPROTO_RANDRPROTO
+ select BR2_PACKAGE_FREETYPE
+ select BR2_PACKAGE_XLIB_LIBX11
+ select BR2_PACKAGE_XLIB_LIBXAU
+ select BR2_PACKAGE_XLIB_LIBXAW
+ select BR2_PACKAGE_XLIB_LIBXDMCP
+ select BR2_PACKAGE_XLIB_LIBXEXT
+ select BR2_PACKAGE_XLIB_LIBXFIXES
+ select BR2_PACKAGE_XLIB_LIBXI
+ select BR2_PACKAGE_XLIB_LIBXMU
+ select BR2_PACKAGE_XLIB_LIBXPM
+ select BR2_PACKAGE_XLIB_LIBXRENDER
+ select BR2_PACKAGE_XLIB_LIBXRES
+ select BR2_PACKAGE_XLIB_LIBXTST
+ select BR2_PACKAGE_XLIB_LIBXXF86MISC
+ select BR2_PACKAGE_XLIB_LIBXXF86VM
+ select BR2_PACKAGE_XLIB_LIBLBXUTIL
+ select BR2_PACKAGE_XLIB_LIBXKBFILE
+ select BR2_PACKAGE_XLIB_XTRANS
+ select BR2_PACKAGE_XDATA_XBITMAPS
+ select BR2_PACKAGE_XPROTO_BIGREQSPROTO
+ select BR2_PACKAGE_XPROTO_EVIEEXT
+ select BR2_PACKAGE_XPROTO_FONTSPROTO
+ select BR2_PACKAGE_XPROTO_INPUTPROTO
+ select BR2_PACKAGE_XPROTO_RECORDPROTO
+ select BR2_PACKAGE_XPROTO_RENDERPROTO
+ select BR2_PACKAGE_XPROTO_RESOURCEPROTO
+ select BR2_PACKAGE_XPROTO_TRAPPROTO
+ select BR2_PACKAGE_XPROTO_VIDEOPROTO
+ select BR2_PACKAGE_XPROTO_XCMISCPROTO
+ select BR2_PACKAGE_XPROTO_XEXTPROTO
+ select BR2_PACKAGE_XPROTO_XF86BIGFONTPROTO
+ select BR2_PACKAGE_XPROTO_XF86DGAPROTO
+ select BR2_PACKAGE_XPROTO_XF86DRIPROTO
+ select BR2_PACKAGE_XPROTO_XF86MISCPROTO
+ select BR2_PACKAGE_XPROTO_XF86RUSHPROTO
+ select BR2_PACKAGE_XPROTO_XF86VIDMODEPROTO
+ select BR2_PACKAGE_XPROTO_XPROTO
+ help
+ xorg-server 1.2.0
+ No description available
diff --git a/package/x11r7/xserver_xorg-server/xserver_xorg-server-1.2.0-xf86ScanPci-no-optimize.patch b/package/x11r7/xserver_xorg-server/xserver_xorg-server-1.2.0-xf86ScanPci-no-optimize.patch
new file mode 100644
index 000000000..145a6d54f
--- /dev/null
+++ b/package/x11r7/xserver_xorg-server/xserver_xorg-server-1.2.0-xf86ScanPci-no-optimize.patch
@@ -0,0 +1,10 @@
+--- xserver_xorg-server-1.2.0/hw/xfree86/scanpci/Makefile.am.orig 2007-06-24 08:46:24.000000000 +0200
++++ xserver_xorg-server-1.2.0/hw/xfree86/scanpci/Makefile.am 2007-06-24 08:46:26.000000000 +0200
+@@ -9,6 +9,7 @@
+ INCLUDES = $(XORG_INCS)
+
+ AM_CFLAGS = $(XORG_CFLAGS)
++CFLAGS += -O0
+
+ BUILT_SOURCES = xf86PciIds.h
+
diff --git a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
new file mode 100644
index 000000000..942456a68
--- /dev/null
+++ b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# xserver_xorg-server -- No description available
+#
+################################################################################
+
+XSERVER_XORG_SERVER_VERSION = 1.2.0
+XSERVER_XORG_SERVER_SOURCE = xorg-server-$(XSERVER_XORG_SERVER_VERSION).tar.bz2
+XSERVER_XORG_SERVER_SITE = http://xorg.freedesktop.org/releases/individual/xserver
+XSERVER_XORG_SERVER_AUTORECONF = YES
+XSERVER_XORG_SERVER_INSTALL_STAGING = YES
+XSERVER_XORG_SERVER_DEPENDANCIES = xlib_libXfont libdrm xlib_libxkbui xproto_compositeproto xproto_damageproto xproto_fixesproto xproto_glproto xproto_kbproto xproto_randrproto freetype xlib_libX11 xlib_libXau xlib_libXaw xlib_libXdmcp xlib_libXext xlib_libXfixes xlib_libXi xlib_libXmu xlib_libXpm xlib_libXrender xlib_libXres xlib_libXtst xlib_libXxf86misc xlib_libXxf86vm xlib_liblbxutil xlib_libxkbfile xlib_xtrans xdata_xbitmaps xproto_bigreqsproto xproto_evieext xproto_fontsproto xproto_inputproto xproto_recordproto xproto_renderproto xproto_resourceproto xproto_trapproto xproto_videoproto xproto_xcmiscproto xproto_xextproto xproto_xf86bigfontproto xproto_xf86dgaproto xproto_xf86driproto xproto_xf86miscproto xproto_xf86rushproto xproto_xf86vidmodeproto xproto_xproto
+XSERVER_XORG_SERVER_CONF_OPT = --disable-xprint --disable-xinerama --disable-xnest --disable-xvfb --disable-dmx --enable-dri --disable-xdmcp --disable-screensaver
+
+$(eval $(call AUTOTARGETS,xserver_xorg-server))