summaryrefslogtreecommitdiff
path: root/package/xl2tp/xl2tp.mk
diff options
context:
space:
mode:
authorMartin Banky <martin.banky@gmail.com>2010-12-12 22:54:05 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-14 01:35:41 +0100
commit767dce8cee8b295ce91bc0ac1d71287eef4be08a (patch)
treeb416a4339657c5e6091122d34bc506af4870cbc2 /package/xl2tp/xl2tp.mk
parentfc13fc7b57844429e09bd49d84f86b54971fc487 (diff)
l2tp: convert to gentargets and change to xl2tp
l2tp is no longer being developed, and xl2tpd is forked from l2tpd and is maintained by Xelerance Corporation. [Peter: remove invalid pppd dependency] Signed-off-by: Martin Banky <Martin.Banky@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/xl2tp/xl2tp.mk')
-rw-r--r--package/xl2tp/xl2tp.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/package/xl2tp/xl2tp.mk b/package/xl2tp/xl2tp.mk
new file mode 100644
index 000000000..bcaacf3ba
--- /dev/null
+++ b/package/xl2tp/xl2tp.mk
@@ -0,0 +1,33 @@
+#############################################################
+#
+# xl2tp
+#
+#############################################################
+XL2TP_VERSION = 1.2.7
+XL2TP_SOURCE = xl2tpd-$(XL2TP_VERSION).tar.gz
+XL2TP_SITE = ftp://ftp.xelerance.com/xl2tpd/
+
+XL2TP_DEPENDENCIES = libpcap
+
+define XL2TP_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define XL2TP_INSTALL_TARGET_CMDS
+ $(MAKE) DESTDIR=$(TARGET_DIR) PREFIX=/usr -C $(@D) install
+endef
+
+define XL2TP_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/bin/pfc
+ rm -f $(TARGET_DIR)/usr/sbin/xl2tpd
+ rm -f $(TARGET_DIR)/usr/share/man/man1/pfc.1
+ rm -f $(TARGET_DIR)/usr/share/man/man8/xl2tpd.8
+ rm -f $(TARGET_DIR)/usr/share/man/man5/xl2tpd.conf.5
+ rm -f $(TARGET_DIR)/usr/share/man/man5/l2tp-secrets.5
+endef
+
+define XL2TP_CLEAN_CMDS
+ -$(MAKE) -C $(@D) clean
+endef
+
+$(eval $(call GENTARGETS,package,xl2tp))