summaryrefslogtreecommitdiff
path: root/package/zlib/zlib.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/zlib/zlib.mk
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/zlib/zlib.mk')
-rw-r--r--package/zlib/zlib.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/zlib/zlib.mk b/package/zlib/zlib.mk
index 627d11bc0..bb308e043 100644
--- a/package/zlib/zlib.mk
+++ b/package/zlib/zlib.mk
@@ -71,3 +71,11 @@ zlib-clean:
zlib-dirclean:
rm -rf $(ZLIB_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_ZLIB)),y)
+TARGETS+=zlib
+endif