summaryrefslogtreecommitdiff
path: root/package/zlib
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-07-12 19:53:12 +0000
committerEric Andersen <andersen@codepoet.org>2005-07-12 19:53:12 +0000
commitdadad95190710ae2e7c2c0cc9cacf5541f99c6f7 (patch)
tree93d8e20d5016e75aced3b98dd540b31d050ee9ee /package/zlib
parentb5ad3a7944cc37892e8da014a955677558fa4e50 (diff)
Thomas Lundquist writes:
If I understand you correctly, you want the ncurses development headers on the target. a patch for this (named target_headers.patch and includes similar options for a few other libs in buildroot) can be found at: http://www.zelow.no/floppyfw/download/Development/Patches/buildroot/ (a few packages there aswell) it will add an option to put headers on target for ncurses, zlib and openssl. Thomas.
Diffstat (limited to 'package/zlib')
-rw-r--r--package/zlib/Config.in7
-rw-r--r--package/zlib/zlib.mk3
2 files changed, 10 insertions, 0 deletions
diff --git a/package/zlib/Config.in b/package/zlib/Config.in
index e39e8abb0..5b85ff7e4 100644
--- a/package/zlib/Config.in
+++ b/package/zlib/Config.in
@@ -6,3 +6,10 @@ config BR2_PACKAGE_ZLIB
gzip and libpng.
http://www.gzip.org/zlib/
+
+config BR2_PACKAGE_ZLIB_TARGET_HEADERS
+ bool "zlib headers in target"
+ default n
+ depends on BR2_PACKAGE_ZLIB
+ help
+ Put headers files in the target.
diff --git a/package/zlib/zlib.mk b/package/zlib/zlib.mk
index 4b8f92d55..978024a89 100644
--- a/package/zlib/zlib.mk
+++ b/package/zlib/zlib.mk
@@ -79,3 +79,6 @@ zlib-dirclean:
ifeq ($(strip $(BR2_PACKAGE_ZLIB)),y)
TARGETS+=zlib
endif
+ifeq ($(strip $(BR2_PACKAGE_ZLIB_TARGET_HEADERS)),y)
+TARGETS+=zlib-headers
+endif