summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-26 09:22:52 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-26 09:22:52 +0000
commit2440801bd1e0a9b5b3388aec3dd78056365c70cf (patch)
tree15ea9595ac5ca4460daf80591025d4d7837bd8db /package
parent3c0dea728ec32a40c14679066935b0fbf498f21a (diff)
mplayer: add -fomit-frame-pointer for i386
This seems to be required to compile some of the inline asm. This solves the following compiler errors: h264.c: In function 'decode_cabac_residual': h264.c:6158: warning: passing argument 4 of 'decode_significance_8x8_x86' discards qualifiers from pointer target type cabac.h: In function 'get_cabac_noinline': cabac.h:513: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm' cabac.h:513: error: 'asm' operand has impossible constraints While searching several weeks ago, I hit the following URL, which unfortunately currently doesn't seem to work anymore and I can't remember what the bug was about. Also see http://bugs.uclibc.org/view.php?id=4604 Signed-off-by: Markus Heidelberg <markus.heidelberg@web.de>
Diffstat (limited to 'package')
-rw-r--r--package/multimedia/mplayer/mplayer.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/multimedia/mplayer/mplayer.mk b/package/multimedia/mplayer/mplayer.mk
index 719cc6754..b65d288a0 100644
--- a/package/multimedia/mplayer/mplayer.mk
+++ b/package/multimedia/mplayer/mplayer.mk
@@ -25,6 +25,11 @@ else
MPLAYER_LARGEFILE:=--disable-largefiles
endif
+ifeq ($(BR2_i386),y)
+# This seems to be required to compile some of the inline asm
+MPLAYER_CFLAGS:=-fomit-frame-pointer
+endif
+
$(DL_DIR)/$(MPLAYER_SOURCE):
$(call DOWNLOAD,$(MPLAYER_SITE),$(MPLAYER_SOURCE))
@@ -38,7 +43,7 @@ $(MPLAYER_DIR)/.configured: $(MPLAYER_DIR)/.unpacked
(cd $(MPLAYER_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
$(TARGET_CONFIGURE_ARGS) \
- CFLAGS="$(TARGET_CFLAGS)" \
+ CFLAGS="$(TARGET_CFLAGS) $(MPLAYER_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
./configure \
--prefix=/usr \