summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-08-04 21:11:01 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-08-04 23:43:54 +0200
commit0e8dafcb3e1ddb7935c1c8c305e7e5598be30315 (patch)
treef2391af5a4ee4935b1d0b9f299702ccb74ba2b0f /package
parentb6d7ce7e021e16f7ab5964c5b5e6e0d0c7657c37 (diff)
sudo: fix main executable permissions
The sudo executable is installed without the setuid bit set, which prevents sudo from working. This patch adds a post-install hook to fix the permissions of the sudo executable. Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/sudo/sudo.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/sudo/sudo.mk b/package/sudo/sudo.mk
index 9b0ebed57..15e06fa3d 100644
--- a/package/sudo/sudo.mk
+++ b/package/sudo/sudo.mk
@@ -14,4 +14,8 @@ SUDO_CONF_OPT = \
--without-interfaces \
--without-pam
+define SUDO_PERMISSIONS
+/usr/bin/sudo f 4755 0 0 - - - - -
+endef
+
$(eval $(autotools-package))