summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorThiago A. CorrĂȘa <thiago.correa@gmail.com>2009-03-11 21:35:07 +0000
committerThiago A. CorrĂȘa <thiago.correa@gmail.com>2009-03-11 21:35:07 +0000
commit149c0d450cfa890d8ca380fd27582ab2af3fff59 (patch)
treecc550acdd1a63c1459d68a8a33c562aaca5a5fb0 /package
parentfcd24512d85f8e51ad7b4e9e621509842c13a8dc (diff)
Let user skip installation of the GUI module for Qtopia
Diffstat (limited to 'package')
-rw-r--r--package/qtopia4/Config.in8
-rw-r--r--package/qtopia4/qtopia4.mk4
2 files changed, 12 insertions, 0 deletions
diff --git a/package/qtopia4/Config.in b/package/qtopia4/Config.in
index f29d186a4..fc5a95eb8 100644
--- a/package/qtopia4/Config.in
+++ b/package/qtopia4/Config.in
@@ -88,6 +88,13 @@ config BR2_PACKAGE_QTOPIA4_QT3SUPPORT
library with proxy code and increase the space required on target.
If unsure say n.
+config BR2_PACKAGE_QTOPIA4_GUI_MODULE
+ bool "Gui Module"
+ help
+ Turns on support to Gui applications. If your board don't have
+ video output, or you don't require Qt GUI, say n.
+
+if BR2_PACKAGE_QTOPIA4_GUI_MODULE
menu "Pixel depths"
comment "Deselecting each option leads to Qt's default (8,16,32)"
@@ -128,6 +135,7 @@ config BR2_PACKAGE_QTOPIA4_PIXEL_DEPTH_32
endif
endmenu
+endif
config BR2_PACKAGE_QTOPIA4_GIF
bool "Enable GIF support"
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index 569966ed4..9f28ff1c0 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -420,6 +420,10 @@ ifeq ($(BR2_PACKAGE_QTOPIA4_PHONON),y)
cp -dpfr $(STAGING_DIR)/usr/plugins/phonon_backend $(TARGET_DIR)/usr/plugins/
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/plugins/phonon_backend/*
endif
+ifneq ($(BR2_PACKAGE_QTOPIA4_GUI_MODULE),y)
+ # Remove Gui library, not needed
+ -rm $(TARGET_DIR)/usr/lib/libQtGui*
+endif
ifneq ($(BR2_PACKAGE_QTOPIA4_SQL_MODULE),y)
# Remove Sql libraries, not needed
-rm $(TARGET_DIR)/usr/lib/libQtSql*