summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-07-20 22:46:15 +0000
committerEric Andersen <andersen@codepoet.org>2006-07-20 22:46:15 +0000
commit275d95c887a4494172555a0e18969c1ef6ab911a (patch)
tree8ebd9a3d761b1e929b61ce640bda6beb4545dfd5 /package
parent7f408ff90ffe0d338c9fcfeab36d18e2c8c33a33 (diff)
fix build and add some basic setup so it can run
Diffstat (limited to 'package')
-rw-r--r--package/xorg/xorg-config.patch5
-rw-r--r--package/xorg/xorg-mmx.patch19
-rw-r--r--package/xorg/xorg-noxf86cfg.patch13
-rw-r--r--package/xorg/xorg.conf116
-rw-r--r--package/xorg/xorg.mk26
5 files changed, 167 insertions, 12 deletions
diff --git a/package/xorg/xorg-config.patch b/package/xorg/xorg-config.patch
index ea051c589..580362cd5 100644
--- a/package/xorg/xorg-config.patch
+++ b/package/xorg/xorg-config.patch
@@ -1,6 +1,6 @@
--- xc/config/cf/host.def~ Thu May 12 15:28:01 MDT 2005
+++ xc/config/cf/host.def Thu May 12 15:28:01 MDT 2005
-@@ -0,0 +1,42 @@
+@@ -0,0 +1,43 @@
+#define KDriveXServer YES
+#define TinyXServer YES
+#define XfbdevServer YES
@@ -32,7 +32,8 @@
+#define BuildIPv6 NO
+#define HasPam NO
+#define HasPamMisc NO
-+
++#define BuildXterm NO
++#define BuildXFree86ConfigTools NO
+/*
+#define XF86CardDrivers mga glint nv tga s3virge sis rendition \
+ neomagic i740 tdfx savage \
diff --git a/package/xorg/xorg-mmx.patch b/package/xorg/xorg-mmx.patch
new file mode 100644
index 000000000..53219523a
--- /dev/null
+++ b/package/xorg/xorg-mmx.patch
@@ -0,0 +1,19 @@
+--- xc/programs/Xserver/fb/Imakefile.orig 2006-07-20 11:41:36.000000000 -0600
++++ xc/programs/Xserver/fb/Imakefile 2006-07-20 11:43:50.000000000 -0600
+@@ -3,16 +3,6 @@
+ XCOMM
+ XCOMM Id: Imakefile,v 1.1 1999/11/02 03:54:44 keithp Exp $
+
+-#if defined(i386Architecture) && defined(HasGcc34) && HasGcc34
+-MMXOPTIONS= -mmmx -Winline --param inline-unit-growth=10000 \
+- --param large-function-growth=10000 -DUSE_GCC34_MMX
+-
+-SpecialCObjectRule(fbmmx,fbmmx.c,$(MMXOPTIONS))
+-SpecialCObjectRule(fbpict,fbpict.c,$(MMXOPTIONS))
+-SpecialCObjectRule(fbfill,fbfill.c,$(MMXOPTIONS))
+-
+-#endif
+-
+ #if DoLoadableServer
+ #if !BuildModuleInSubdir
+ #define IHaveModules
diff --git a/package/xorg/xorg-noxf86cfg.patch b/package/xorg/xorg-noxf86cfg.patch
new file mode 100644
index 000000000..37828e480
--- /dev/null
+++ b/package/xorg/xorg-noxf86cfg.patch
@@ -0,0 +1,13 @@
+--- xc/programs/Xserver/hw/xfree86/Imakefile.orig 2006-07-20 12:51:58.000000000 -0600
++++ xc/programs/Xserver/hw/xfree86/Imakefile 2006-07-20 12:52:04.000000000 -0600
+@@ -84,10 +84,6 @@
+ DRIVERSDK = sdk
+ #endif
+
+-#if !BuildServersOnly || BuildXFree86ConfigTools
+-XF86CFGDIRS = xf86cfg xf86config
+-#endif
+-
+ SUBDIRS = os-support common $(I2CDIR) $(XAADIR) $(XF1BPPDIR) $(XF4BPPDIR) \
+ $(XF8_32BPPDIR) $(XF8_16BPPDIR) $(XF24_32BPPDIR) $(SHADOWFBDIR) \
+ drivers $(LOADERDIR) $(VGAHWDIR) $(FBDEVHWDIR) $(RAMDACDIR) \
diff --git a/package/xorg/xorg.conf b/package/xorg/xorg.conf
new file mode 100644
index 000000000..ceb17eadf
--- /dev/null
+++ b/package/xorg/xorg.conf
@@ -0,0 +1,116 @@
+# XF86Config-4 (XFree86 server configuration file) generated by dexconf, the
+# Debian X Configuration tool, using values from the debconf database.
+#
+# Edit this file with caution, and see the XF86Config-4 manual page.
+# (Type "man XF86Config-4" at the shell prompt.)
+#
+# If you want your changes to this file preserved by dexconf, only make changes
+# before the "### BEGIN DEBCONF SECTION" line above, and/or after the
+# "### END DEBCONF SECTION" line below.
+#
+# To change things within the debconf section, run the command:
+# dpkg-reconfigure xserver-xfree86
+# as root. Also see "How do I add custom sections to a dexconf-generated
+# XF86Config or XF86Config-4 file?" in /usr/share/doc/xfree86-common/FAQ.gz.
+
+Section "Files"
+ FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
+ FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
+ FontPath "/usr/X11R6/lib/X11/fonts/misc"
+EndSection
+
+Section "Module"
+ Load "bitmap"
+ Load "dbe"
+ Load "ddc"
+ Load "freetype"
+ Load "int10"
+EndSection
+
+Section "InputDevice"
+ Identifier "Generic Keyboard"
+ Driver "keyboard"
+ Option "XkbRules" "xfree86"
+ Option "XkbModel" "pc104"
+ Option "XkbLayout" "us"
+ Option "XkbOptions" "altwin:meta_win"
+EndSection
+
+Section "InputDevice"
+ Identifier "PS2 Mouse"
+ Driver "mouse"
+ Option "CorePointer"
+ Option "Device" "/dev/psaux"
+ Option "Protocol" "ImPS/2"
+ Option "ZAxisMapping" "4 5"
+EndSection
+
+Section "InputDevice"
+ Identifier "USB Mouse"
+ Driver "mouse"
+ Option "SendCoreEvents" "true"
+ Option "Device" "/dev/input/mice"
+ Option "Protocol" "ImPS/2"
+ Option "ZAxisMapping" "4 5"
+EndSection
+
+Section "Device"
+ Identifier "Generic VGA Card"
+ Driver "vesa"
+ #Driver "vga"
+ #Driver "fbdev"
+EndSection
+
+Section "Monitor"
+ Identifier "Generic Monitor"
+ #HorizSync 30 - 82
+ #VertRefresh 50 - 85
+ Option "DPMS"
+EndSection
+
+Section "Screen"
+ Identifier "Default Screen"
+ Device "Generic VGA Card"
+ Monitor "Generic Monitor"
+ DefaultDepth 8
+ SubSection "Display"
+ Viewport 0 0
+ Depth 4
+ Modes "640x480"
+ EndSubSection
+ SubSection "Display"
+ Viewport 0 0
+ Depth 8
+ Modes "640x480"
+ EndSubSection
+ SubSection "Display"
+ Viewport 0 0
+ Depth 16
+ Modes "640x480"
+ EndSubSection
+ SubSection "Display"
+ Viewport 0 0
+ Depth 24
+ Modes "640x480"
+ EndSubSection
+EndSection
+
+Section "ServerFlags"
+ Option "BlankTime" "10"
+ Option "StandbyTime" "15"
+ Option "SuspendTime" "20"
+ Option "OffTime" "30"
+EndSection
+
+Section "ServerLayout"
+ Identifier "Default Layout"
+ Screen "Default Screen"
+ InputDevice "Generic Keyboard" "CoreKeyboard"
+ InputDevice "USB Mouse" "CorePointer"
+ InputDevice "PS2 Mouse"
+EndSection
+
+Section "DRI"
+ Mode 0666
+EndSection
+
diff --git a/package/xorg/xorg.mk b/package/xorg/xorg.mk
index dc596f45e..eeb911a8b 100644
--- a/package/xorg/xorg.mk
+++ b/package/xorg/xorg.mk
@@ -9,10 +9,12 @@ ifeq ($(strip $(BR2_PACKAGE_XORG)),y)
XORG_APPS:=xlsfonts/xlsfonts xmodmap/xmodmap xinit/startx \
xauth/xauth xinit/xinit xsetroot/xsetroot xset/xset \
- xterm/xterm mkfontscale/mkfontscale mkfontdir/mkfontdir
+ mkfontscale/mkfontscale mkfontdir/mkfontdir \
+ #xterm/xterm
XORG_LIBS:= Xft fontconfig expat Xrender Xaw Xmu Xt \
- SM ICE Xpm Xp Xext X11 Xmuu
+ SM ICE Xpm Xp Xext X11 Xmuu Xxf86misc
+
#############################################################
# Stuff below this line shouldn't need changes.
@@ -72,6 +74,12 @@ $(XORG_XSERVER): $(XORG_DIR)/.configured
World XCURSORGEN=xcursorgen MKFONTSCALE=mkfontscale )
touch -c $(XORG_XSERVER)
+$(STAGING_DIR)$(TARGET_LIBX)/libX11.so.6.2: $(XORG_XSERVER)
+ -mkdir -p $(STAGING_DIR)$(TARGET_LIBX)
+ ( cd $(XORG_DIR); $(MAKE) \
+ DESTDIR=$(STAGING_DIR) install XCURSORGEN=xcursorgen MKFONTSCALE=mkfontscale )
+ touch -c $(STAGING_DIR)$(TARGET_LIBX)/libX11.so.6.2
+
$(TARGET_XSERVER): $(XORG_XSERVER)
-mkdir -p $(XORG_BINX)
for file in $(XORG_APPS) ; do \
@@ -89,6 +97,9 @@ $(TARGET_XSERVER): $(XORG_XSERVER)
cp -LRf $(XORG_DIR)/fonts/bdf/misc/*.bdf $(XORG_LIBX)/X11/fonts/misc/
( cd $(XORG_LIBX)/X11/fonts/misc/; mkfontdir )
(cd $(TARGET_DIR)/usr/bin; ln -snf $(TARGET_BINX) X11)
+ mkdir -p $(TARGET_DIR)/etc/X11/
+ cp package/xorg/xorg.conf $(TARGET_DIR)/etc/X11/
+ cp -a $(STAGING_DIR)$(TARGET_LIBX)/X11/rgb* $(XORG_LIBX)/X11/
touch -c $(TARGET_XSERVER)
$(XORG_LIBX)/libX11.so.6.2: $(TARGET_XSERVER)
@@ -101,19 +112,14 @@ $(XORG_LIBX)/libX11.so.6.2: $(TARGET_XSERVER)
cp -pRf $$file $(XORG_LIBX) ; \
done
(cd $(TARGET_DIR)/usr/lib; ln -snf $(TARGET_LIBX) X11)
- if [ grep -q '$(TARGET_LIBX)' $(TARGET_DIR)/etc/ld.so.conf ] ; then \
+ touch $(TARGET_DIR)/etc/ld.so.conf
+ if [ "`grep -c '$(TARGET_LIBX)' $(TARGET_DIR)/etc/ld.so.conf`" = "0" ] ; then \
echo "$(TARGET_LIBX)" >> $(TARGET_DIR)/etc/ld.so.conf; \
fi;
touch -c $(XORG_LIBX)/libX11.so.6.2
-$(STAGING_DIR)$(TARGET_LIBX)/libX11.so.6.2: $(XORG_XSERVER)
- -mkdir -p $(STAGING_DIR)$(TARGET_LIBX)
- ( cd $(XORG_DIR); $(MAKE) \
- DESTDIR=$(STAGING_DIR) install XCURSORGEN=xcursorgen MKFONTSCALE=mkfontscale )
- touch -c $(STAGING_DIR)$(TARGET_LIBX)/libX11.so.6.2
-
-xorg: zlib png $(XORG_LIBX)/libX11.so.6.2 $(STAGING_DIR)$(TARGET_LIBX)/libX11.so.6.2
+xorg: zlib png $(STAGING_DIR)$(TARGET_LIBX)/libX11.so.6.2 $(XORG_LIBX)/libX11.so.6.2
xorg-source: $(DL_DIR)/$(XORG_SOURCE)