summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorThiago A. CorrĂȘa <thiago.correa@gmail.com>2008-09-03 01:09:29 +0000
committerThiago A. CorrĂȘa <thiago.correa@gmail.com>2008-09-03 01:09:29 +0000
commit52a7c1681e0528431ae447612a22f47686083a69 (patch)
tree0d18ed475ffdb39bf2f98fdfc52022e9debc4336 /package
parent0ca929e0529dd9887138137ce86eeb25381ce628 (diff)
Qtopia: don't build sqlite driver when SQL module is disabled.
Diffstat (limited to 'package')
-rw-r--r--package/qtopia4/qtopia4.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index b8afdaa01..72632521a 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -182,11 +182,17 @@ QTOPIA4_CONFIGURE+= -qt-sql-psql
endif
ifeq ($(BR2_PACKAGE_QTOPIA4_SQLITE),y)
QTOPIA4_CONFIGURE+= -qt-sql-sqlite
+else
+QTOPIA4_CONFIGURE+= -no-sql-sqlite
endif
ifeq ($(BR2_PACKAGE_QTOPIA4_SQLITE2),y)
QTOPIA4_CONFIGURE+= -qt-sql-sqlite2
endif
+else
# By default, no SQL driver is turned on by configure.
+# but it seams sqlite isn't disabled despite what says
+# configure --help
+QTOPIA4_CONFIGURE+= -no-sql-sqlite
endif
ifeq ($(BR2_PACKAGE_QTOPIA4_XMLPATTERNS),y)