summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2009-06-30 21:40:23 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-06-30 21:40:23 +0200
commit5818010f92c37cdfa2667bc52616f134bc167148 (patch)
tree4ecd864f2314b9bb2371c2be1b57ce50d384a03e /package
parenta928430ff7f8e40f910db6628efd1d923e96a414 (diff)
sqlite: bump version
Closed #333. * Refactor the internal representation of SQL expressions so that they use less memory on embedded platforms. * Reduce the amount of stack space used * Fix an 64-bit alignment bug on HP/UX and Sparc * The sqlite3_create_function() family of interfaces now return SQLITE_MISUSE instead of SQLITE_ERROR when passed invalid parameter combinations. * When new tables are created using CREATE TABLE ... AS SELECT ... the datatype of the columns is the simplified SQLite datatype (TEXT, INT, REAL, NUMERIC, or BLOB) instead of a copy of the original datatype from the source table. * Resolve race conditions when checking for a hot rollback journal. * The sqlite3_shutdown() interface frees all mutexes under windows. * Enhanced robustness against corrupt database files * Continuing improvements to the test suite and fixes to obscure bugs and inconsistencies that the test suite improvements are uncovering. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/database/sqlite/sqlite.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/database/sqlite/sqlite.mk b/package/database/sqlite/sqlite.mk
index 9f10f1e3f..9bceee219 100644
--- a/package/database/sqlite/sqlite.mk
+++ b/package/database/sqlite/sqlite.mk
@@ -4,8 +4,8 @@
#
#############################################################
-SQLITE_VERSION = 3.6.13
-SQLITE_SOURCE = sqlite-$(SQLITE_VERSION).tar.gz
+SQLITE_VERSION = 3.6.15
+SQLITE_SOURCE = sqlite-amalgamation-$(SQLITE_VERSION).tar.gz
SQLITE_SITE = http://www.sqlite.org
SQLITE_INSTALL_STAGING = YES
SQLITE_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install