summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-07-05 21:54:08 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-10 21:30:03 +0200
commit5e0d46138fbba1197f4f9cef4b96c7b87f42a5a1 (patch)
treec3b3157d873af58643ebfb1f7b81202435adf216 /package
parente82604ccdd38aa3ee2884d4f143d8be7106fdbd9 (diff)
uboot-mkimage: new package
The mkimage for the host is now built by a package, so that boot/u-boot/u-boot.mk is no longer responsible for doing this. It makes things a lot easier to handle, as linux/linux.mk now simply depends on host-uboot-mkimage. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/uboot-mkimage/uboot-mkimage-2011.03-drop-configh.patch27
-rw-r--r--package/uboot-mkimage/uboot-mkimage.mk16
2 files changed, 43 insertions, 0 deletions
diff --git a/package/uboot-mkimage/uboot-mkimage-2011.03-drop-configh.patch b/package/uboot-mkimage/uboot-mkimage-2011.03-drop-configh.patch
new file mode 100644
index 000000000..bf524c9a3
--- /dev/null
+++ b/package/uboot-mkimage/uboot-mkimage-2011.03-drop-configh.patch
@@ -0,0 +1,27 @@
+"make tools-all" should allow building tools such as mkimage and the new
+imximage without any config, but imximage.c currently fails to build
+with:
+imximage.h:27:20: error: config.h: No such file or directory
+
+config.h is not needed in imximage.h nor in imximage.c, and imximage.h
+is only included from imximage.c, so drop this include to fix the build.
+
+Signed-off-by: Lo?c Minier <loic.minier@linaro.org>
+---
+ tools/imximage.h | 2 --
+ 1 files changed, 0 insertions(+), 2 deletions(-)
+
+diff --git a/tools/imximage.h b/tools/imximage.h
+index 38ca6be..d126a46 100644
+--- a/tools/imximage.h
++++ b/tools/imximage.h
+@@ -24,8 +24,6 @@
+ #ifndef _IMXIMAGE_H_
+ #define _IMXIMAGE_H_
+
+-#include <config.h>
+-
+ #define MAX_HW_CFG_SIZE_V2 121 /* Max number of registers imx can set for v2 */
+ #define MAX_HW_CFG_SIZE_V1 60 /* Max number of registers imx can set for v1 */
+ #define APP_CODE_BARKER 0xB1
+-- 1.7.2.3
diff --git a/package/uboot-mkimage/uboot-mkimage.mk b/package/uboot-mkimage/uboot-mkimage.mk
new file mode 100644
index 000000000..055348c3c
--- /dev/null
+++ b/package/uboot-mkimage/uboot-mkimage.mk
@@ -0,0 +1,16 @@
+UBOOT_MKIMAGE_VERSION = 2011.03
+UBOOT_MKIMAGE_SOURCE = u-boot-$(UBOOT_MKIMAGE_VERSION).tar.bz2
+UBOOT_MKIMAGE_SITE = ftp://ftp.denx.de/pub/u-boot
+
+define HOST_UBOOT_MKIMAGE_BUILD_CMDS
+ $(MAKE) -C $(@D) \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ ARCH=$(U_BOOT_ARCH) \
+ tools
+endef
+
+define HOST_UBOOT_MKIMAGE_INSTALL_CMDS
+ install -m 0755 -D $(@D)/tools/mkimage $(HOST_DIR)/usr/bin
+endef
+
+$(eval $(call GENTARGETS,package,uboot-mkimage,host))