summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-24 09:17:56 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-24 09:17:56 +0200
commit8e26abecd00f4899fb122c3eeb03fbdf20cda32e (patch)
treece3b2d771ca5952f6d31eccfda9afc75d438a9af /package
parentb3afe4657615a0d5454668927041842ed33bbc97 (diff)
pkg-generic: fix SUBDIR handling
Commit 9ba9bfb9a02706fa414bcf4c6dcceac1b68a5c9a inverted the logic to define $(2)_SUBDIR, breaking the build of things using the _SUBDIR feature, like the tcl package. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/pkg-generic.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 8a730c0a0..d1f4f2a2c 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -204,11 +204,11 @@ $(2)_BASE_NAME = $(1)-$$($(2)_VERSION)
$(2)_DL_DIR = $$(DL_DIR)/$$($(2)_BASE_NAME)
$(2)_DIR = $$(BUILD_DIR)/$$($(2)_BASE_NAME)
-ifndef $(3)_SUBDIR
- ifdef $(2)_SUBDIR
- $(3)_SUBDIR = $$($(2)_SUBDIR)
+ifndef $(2)_SUBDIR
+ ifdef $(3)_SUBDIR
+ $(2)_SUBDIR = $$($(3)_SUBDIR)
else
- $(3)_SUBDIR ?=
+ $(2)_SUBDIR ?=
endif
endif