summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorThiago A. CorrĂȘa <thiago.correa@gmail.com>2009-03-12 02:53:54 +0000
committerThiago A. CorrĂȘa <thiago.correa@gmail.com>2009-03-12 02:53:54 +0000
commitba567f8a582cdf3ec59a9187c42e1294f860f5f0 (patch)
tree5c070408501ef40bfa0c5833b4aeead2737bf79f /package
parentafaa374590adc5153067e958472a719d186769ce (diff)
Update Qtopia to 4.5.0, which introduces a new licensing option: LGPL. This will be default now.
Diffstat (limited to 'package')
-rw-r--r--package/qtopia4/Config.in22
-rw-r--r--package/qtopia4/qtopia4.mk4
2 files changed, 15 insertions, 11 deletions
diff --git a/package/qtopia4/Config.in b/package/qtopia4/Config.in
index e6823329b..2442c2d17 100644
--- a/package/qtopia4/Config.in
+++ b/package/qtopia4/Config.in
@@ -41,10 +41,13 @@ endchoice
choice
prompt "Qtopia 4 Core license type"
- default BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_GPL
+ default BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_LGPL
help
Selects the type of license you which to use for Qtopia 4 Core.
+config BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_LGPL
+ bool "LGPL license"
+
config BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_GPL
bool "GPL license"
@@ -53,16 +56,17 @@ config BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_COMMERCIAL
endchoice
-config BR2_PACKAGE_QTOPIA4_GPL_LICENSE_APPROVED
- bool "Approve Qtopia Core 4 GPL licence"
- depends on BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_GPL
+config BR2_PACKAGE_QTOPIA4_LICENSE_APPROVED
+ bool "Approve Qtopia Core 4 license"
+ depends on BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_GPL || BR2_PACKAGE_QTOPIA4_LICENSE_TYPE_LGPL
help
- Select this if you approve the GNU GENERAL PUBLIC LICENSE Version 2
- on the Qtopia Core 4 library. By doing this you will not be asked
- while the library is compiled. Please read and understand the GPL
- licence before approving this.
+ Select this if you approve the above selected license for the
+ Qtopia Core 4 library.
+ By doing this you will not be asked while the library is compiled.
+ Please read and understand the license terms before approving this.
- For full GPL version 2 see http://www.gnu.org/licenses/gpl.txt
+ For full GPL version 2 see http://www.gnu.org/licenses/gpl2.txt
+ For full LGPL see http://www.gnu.org/licenses/lgpl.txt
config BR2_PACKAGE_QTOPIA4_COMMERCIAL_USERNAME
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index 9f28ff1c0..3f46c13d2 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -16,7 +16,7 @@
# (cd /usr/include; sudo ln -s dbus-1.0/dbus dbus)
# to fix
-QTOPIA4_VERSION:=4.4.3
+QTOPIA4_VERSION:=4.5.0
QTOPIA4_CAT:=$(BZCAT)
BR2_PACKAGE_QTOPIA4_COMMERCIAL_USERNAME:=$(strip $(subst ",, $(BR2_PACKAGE_QTOPIA4_COMMERCIAL_USERNAME)))
@@ -36,7 +36,7 @@ else # Good, good, we are free:
QTOPIA4_SITE=ftp://ftp.trolltech.com/qt/source
QTOPIA4_SOURCE:=qt-embedded-linux-opensource-src-$(QTOPIA4_VERSION).tar.bz2
QTOPIA4_TARGET_DIR:=$(BUILD_DIR)/qt-embedded-linux-opensource-src-$(QTOPIA4_VERSION)
-ifeq ($(BR2_PACKAGE_QTOPIA4_GPL_LICENSE_APPROVED),y)
+ifeq ($(BR2_PACKAGE_QTOPIA4_LICENSE_APPROVED),y)
QTOPIA4_CONFIGURE+= -confirm-license
endif
endif